summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-28 22:32:40 +0000
committerSam James <sam@gentoo.org>2021-02-28 23:04:31 +0000
commitbe214f59a2387da65ae4665cbe1639a9c3e6bb42 (patch)
tree3ef61cbf62bd24f289a930eda1e209ca4d22e4d4 /games-strategy
parentgames-strategy/0ad: update comments in ebuild (diff)
downloadgentoo-be214f59a2387da65ae4665cbe1639a9c3e6bb42.tar.gz
gentoo-be214f59a2387da65ae4665cbe1639a9c3e6bb42.tar.bz2
gentoo-be214f59a2387da65ae4665cbe1639a9c3e6bb42.zip
games-strategy/0ad: use multiprocessing.eclass
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.24b_alpha.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild b/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
index 1a15d95383c6..cde93c077b30 100644
--- a/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
+++ b/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
@@ -5,7 +5,7 @@ EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit desktop toolchain-funcs wxwidgets xdg
+inherit desktop toolchain-funcs multiprocessing wxwidgets xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -145,7 +145,7 @@ src_compile() {
if use nvtt ; then
cd libraries/source/nvtt || die
elog "Building bundled nvtt (bug #768930)"
- ./build.sh JOBS="-j3" || die "Failed to build bundled nvtt"
+ ./build.sh JOBS="-j$(makeopts_jobs)" || die "Failed to build bundled nvtt"
cd "${S}" || die
fi
@@ -155,12 +155,12 @@ src_compile() {
# e.g. bug #768840.
cd libraries/source/spidermonkey || die
elog "Building bundled SpiderMonkey (bug #768840)"
- XARGS="${EPREFIX}/usr/bin/xargs" ./build.sh JOBS="-j3" || die "Failed to build bundled SpiderMonkey"
+ XARGS="${EPREFIX}/usr/bin/xargs" ./build.sh JOBS="-j(makeopts_jobs)" || die "Failed to build bundled SpiderMonkey"
cd "${S}" || die
# build 0ad
elog "Building 0ad"
- emake -C build/workspaces/gcc verbose=1 JOBS="-j3"
+ emake -C build/workspaces/gcc verbose=1 JOBS="-j$(makeopts_jobs)"
# Merged from 0ad-data
# bug #771147 (comment 3)