summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2018-08-26 18:17:14 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-24 08:20:54 +0200
commit5ee30ef790d2a621dda91db7c7989ecc0196df71 (patch)
tree89d5c22e2ef22688c612f03a9d9cffc52a86496f /games-util/gamemode
parentnet-misc/rclone: drop old (diff)
downloadgentoo-5ee30ef790d2a621dda91db7c7989ecc0196df71.tar.gz
gentoo-5ee30ef790d2a621dda91db7c7989ecc0196df71.tar.bz2
gentoo-5ee30ef790d2a621dda91db7c7989ecc0196df71.zip
games-util/gamemode: New ebuild suggestion
GameMode from Feral Interactive is a systemd daemon allowing games to adjust the system to performance mode. It is supported by newer Feral titles and also supports other games by preloading a lib. Closes: https://bugs.gentoo.org/652906 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Signed-off-by: Kai Krakow <kai@kaishome.de> Co-authored-by: Mike Lothian <mike@fireburn.co.uk> Co-authored-by: Erik Badman <erik.badman@yahoo.com> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9700
Diffstat (limited to 'games-util/gamemode')
-rw-r--r--games-util/gamemode/Manifest1
-rw-r--r--games-util/gamemode/gamemode-1.2.ebuild102
-rw-r--r--games-util/gamemode/gamemode-9999.ebuild102
-rw-r--r--games-util/gamemode/metadata.xml16
4 files changed, 221 insertions, 0 deletions
diff --git a/games-util/gamemode/Manifest b/games-util/gamemode/Manifest
new file mode 100644
index 000000000000..9efa7de80bde
--- /dev/null
+++ b/games-util/gamemode/Manifest
@@ -0,0 +1 @@
+DIST gamemode-1.2.tar.xz 38536 BLAKE2B af39b8c0585c522afa72238b8332a6a5301d36b3c53e50652a78c41788eae9f5cb319cad06eaf6f345c50f934e188df4c78d70efbad919dd6897d3350d14e568 SHA512 233602e5e93b6cfcc742510dafb00dc826000d0c8618a693e9a579dc3b31c546d22c0545084cfb78c6085226e6b0e26c066078bc1871d36d5fb90828cf63cea9
diff --git a/games-util/gamemode/gamemode-1.2.ebuild b/games-util/gamemode/gamemode-1.2.ebuild
new file mode 100644
index 000000000000..6ac471006aa0
--- /dev/null
+++ b/games-util/gamemode/gamemode-1.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils user
+
+DESCRIPTION="Optimise Linux system performance on demand"
+HOMEPAGE="https://github.com/FeralInteractive/gamemode"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
+ GAMEMODE_GIT_PTR="master"
+ inherit git-r3
+else
+ GAMEMODE_GIT_PTR="${PV}"
+ SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/systemd-236[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ elog
+ elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"
+ elog "feature. Examples of kernels providing that are sys-kernel/ck-source"
+ elog "and sys-kernel/pf-sources."
+ elog
+ elog "Support for soft realtime is completely optional. It may provide the"
+ elog "following benefits with systems having at least four CPU cores:"
+ elog
+ elog " * more CPU shares allocated exclusively to the game"
+ elog " * reduced input lag and reduced thread latency"
+ elog " * more consistent frame times resulting in less microstutters"
+ elog
+ elog "You probably won't benefit from soft realtime mode and thus don't need"
+ elog "SCHED_ISO if:"
+ elog
+ elog " * Your CPU has less than four cores because the game may experience"
+ elog " priority inversion with the graphics driver (thus heuristics"
+ elog " automatically disable SCHED_ISO usage then)"
+ elog " * Your game uses busy-loops to interface with the graphics driver"
+ elog " but you may still force SCHED_ISO per configuation file, YMMV,"
+ elog " it depends on the graphics driver implementation, i.e. usage of"
+ elog " __GL_THREADED_OPTIMIZATIONS or similar."
+ elog " * If your game causes more than 70% CPU usage across all cores,"
+ elog " SCHED_ISO automatically turns off and on depending on usage and"
+ elog " is processed with higher-than-normal priority then (renice)."
+ elog " This auto-switching may result in a lesser game experience."
+ elog
+ elog "For more info look at:"
+ elog "https://github.com/FeralInteractive/gamemode/blob/${GAMEMODE_GIT_PTR}/README.md"
+ elog
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ -Dwith-examples=false
+ -Dwith-daemon=false
+ )
+ fi
+ meson_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+ insinto /etc/security/limits.d
+ newins - 45-gamemode.conf <<-EOF
+ @gamemode - nice -10
+ EOF
+}
+
+pkg_postinst() {
+ enewgroup gamemode
+
+ elog
+ elog "GameMode can renice your games. You need to be in the gamemode group for this to work."
+ elog "Run the following command as root to add your user:"
+ elog "# gpasswd -a USER gamemode # with USER = your user name"
+ elog
+
+ elog "Enable and start the daemon in your systemd user instance, then add"
+ elog "LD_PRELOAD=\$LD_PRELOAD:/usr/\$LIB/libgamemodeauto.so %command%"
+ elog "to the start options of any steam game to enable the performance"
+ elog "governor as you start the game."
+ elog
+}
diff --git a/games-util/gamemode/gamemode-9999.ebuild b/games-util/gamemode/gamemode-9999.ebuild
new file mode 100644
index 000000000000..6ac471006aa0
--- /dev/null
+++ b/games-util/gamemode/gamemode-9999.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils user
+
+DESCRIPTION="Optimise Linux system performance on demand"
+HOMEPAGE="https://github.com/FeralInteractive/gamemode"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
+ GAMEMODE_GIT_PTR="master"
+ inherit git-r3
+else
+ GAMEMODE_GIT_PTR="${PV}"
+ SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/systemd-236[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ elog
+ elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"
+ elog "feature. Examples of kernels providing that are sys-kernel/ck-source"
+ elog "and sys-kernel/pf-sources."
+ elog
+ elog "Support for soft realtime is completely optional. It may provide the"
+ elog "following benefits with systems having at least four CPU cores:"
+ elog
+ elog " * more CPU shares allocated exclusively to the game"
+ elog " * reduced input lag and reduced thread latency"
+ elog " * more consistent frame times resulting in less microstutters"
+ elog
+ elog "You probably won't benefit from soft realtime mode and thus don't need"
+ elog "SCHED_ISO if:"
+ elog
+ elog " * Your CPU has less than four cores because the game may experience"
+ elog " priority inversion with the graphics driver (thus heuristics"
+ elog " automatically disable SCHED_ISO usage then)"
+ elog " * Your game uses busy-loops to interface with the graphics driver"
+ elog " but you may still force SCHED_ISO per configuation file, YMMV,"
+ elog " it depends on the graphics driver implementation, i.e. usage of"
+ elog " __GL_THREADED_OPTIMIZATIONS or similar."
+ elog " * If your game causes more than 70% CPU usage across all cores,"
+ elog " SCHED_ISO automatically turns off and on depending on usage and"
+ elog " is processed with higher-than-normal priority then (renice)."
+ elog " This auto-switching may result in a lesser game experience."
+ elog
+ elog "For more info look at:"
+ elog "https://github.com/FeralInteractive/gamemode/blob/${GAMEMODE_GIT_PTR}/README.md"
+ elog
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ -Dwith-examples=false
+ -Dwith-daemon=false
+ )
+ fi
+ meson_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+ insinto /etc/security/limits.d
+ newins - 45-gamemode.conf <<-EOF
+ @gamemode - nice -10
+ EOF
+}
+
+pkg_postinst() {
+ enewgroup gamemode
+
+ elog
+ elog "GameMode can renice your games. You need to be in the gamemode group for this to work."
+ elog "Run the following command as root to add your user:"
+ elog "# gpasswd -a USER gamemode # with USER = your user name"
+ elog
+
+ elog "Enable and start the daemon in your systemd user instance, then add"
+ elog "LD_PRELOAD=\$LD_PRELOAD:/usr/\$LIB/libgamemodeauto.so %command%"
+ elog "to the start options of any steam game to enable the performance"
+ elog "governor as you start the game."
+ elog
+}
diff --git a/games-util/gamemode/metadata.xml b/games-util/gamemode/metadata.xml
new file mode 100644
index 000000000000..05078a2e7821
--- /dev/null
+++ b/games-util/gamemode/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hurikhan77+bgo@gmail.com</email>
+ <name>Kai Krakow</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/FeralInteractive/gamemode/issues</bugs-to>
+ <remote-id type="github">FeralInteractive/gamemode</remote-id>
+ </upstream>
+</pkgmetadata>