summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/linux-wbfs-manager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/linux-wbfs-manager')
-rw-r--r--games-util/linux-wbfs-manager/Manifest1
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild50
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild50
-rw-r--r--games-util/linux-wbfs-manager/metadata.xml8
4 files changed, 109 insertions, 0 deletions
diff --git a/games-util/linux-wbfs-manager/Manifest b/games-util/linux-wbfs-manager/Manifest
new file mode 100644
index 000000000000..eea836f29edb
--- /dev/null
+++ b/games-util/linux-wbfs-manager/Manifest
@@ -0,0 +1 @@
+DIST linux-wbfs-manager-0.1.12.tar.gz 34251 SHA256 45e09fb014bd28ab6181a383fbb74f2979a46b1d8ce8752389a7dc543f287c7c SHA512 58ac4d110e27123d04261d618df8734a0471bcad63171025aa4766a73bcc4a9240fceec59b1ba91fff71230e98f57b5fdd12390d380dc0c41d08740b7076bf6f WHIRLPOOL 65bcb3b44a225caf1dd92bc6487aaea4ff4f248e3b013d3d07eaf000af2d999a50df72f9ec235dcf9e549bcbaddce05bc865d905ca1e4348b50bc17a56b6712d
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
new file mode 100644
index 000000000000..aea44b508df1
--- /dev/null
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+if [[ "${PV}" == "9999" ]]; then
+ ESVN_REPO_URI="http://linux-wbfs-manager.googlecode.com/svn/trunk/"
+ inherit toolchain-funcs subversion
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ inherit toolchain-funcs
+ SRC_URI="http://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+ KEYWORDS="amd64 ~ppc x86"
+fi;
+
+DESCRIPTION="WBFS manager for Linux using GTK+"
+HOMEPAGE="http://code.google.com/p/linux-wbfs-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${PN}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ subversion_src_unpack
+ else
+ default
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wbfs_gtk
+ dodoc README
+}
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
new file mode 100644
index 000000000000..202cdcede763
--- /dev/null
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+if [[ "${PV}" == "9999" ]]; then
+ ESVN_REPO_URI="http://linux-wbfs-manager.googlecode.com/svn/trunk/"
+ inherit toolchain-funcs subversion
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ inherit toolchain-funcs
+ SRC_URI="http://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi;
+
+DESCRIPTION="WBFS manager for Linux using GTK+"
+HOMEPAGE="http://code.google.com/p/linux-wbfs-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${PN}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ subversion_src_unpack
+ else
+ default
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wbfs_gtk
+ dodoc README
+}
diff --git a/games-util/linux-wbfs-manager/metadata.xml b/games-util/linux-wbfs-manager/metadata.xml
new file mode 100644
index 000000000000..509881960887
--- /dev/null
+++ b/games-util/linux-wbfs-manager/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="google-code">linux-wbfs-manager</remote-id>
+ </upstream>
+</pkgmetadata>