summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOursDesCavernes <totocoq@yahoo.fr>2020-03-17 21:34:48 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-25 15:45:22 +0200
commitada436281857e5cd4033f569834dcbcb7cc0e7bb (patch)
treef6361d7215e016e51a8b6a1f4dc5efa87556e842 /games-util/springlobby/springlobby-0.269.ebuild
parentdev-python/zipp: s390 stable wrt bug #714578 (diff)
downloadgentoo-ada436281857e5cd4033f569834dcbcb7cc0e7bb.tar.gz
gentoo-ada436281857e5cd4033f569834dcbcb7cc0e7bb.tar.bz2
gentoo-ada436281857e5cd4033f569834dcbcb7cc0e7bb.zip
games-util/springlobby: 0.269 version bump
Signed-off-by: Thomas Coquelin <totocoq@yahoo.fr> Closes: https://bugs.gentoo.org/708400 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/14997 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-util/springlobby/springlobby-0.269.ebuild')
-rw-r--r--games-util/springlobby/springlobby-0.269.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-util/springlobby/springlobby-0.269.ebuild b/games-util/springlobby/springlobby-0.269.ebuild
new file mode 100644
index 000000000000..e8b393a9a6d1
--- /dev/null
+++ b/games-util/springlobby/springlobby-0.269.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0"
+inherit cmake xdg-utils wxwidgets
+
+DESCRIPTION="The official lobby client for SpringRTS community games"
+HOMEPAGE="https://springlobby.springrts.com"
+SRC_URI="https://springlobby.springrts.com/dl/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libnotify +nls +sound"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-libs/zlib[minizip]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ libnotify? ( x11-libs/libnotify )
+ sound? (
+ media-libs/alure
+ media-libs/openal
+ )
+"
+
+BDEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DOPTION_NOTIFY=$(usex libnotify)
+ -DOPTION_SOUND=$(usex sound)
+ -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
+ -DAUX_VERSION="(Gentoo,${ARCH})"
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}