summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Zuber <a.zuber@gmx.ch>2020-04-07 08:49:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-10 13:30:02 +0300
commit35001519192bf033a769facfa49865b2f5baa36c (patch)
tree7ee70c845ef312e221fc1ab179d0a44e3f6ad9fb /games-util
parentgames-util/pyfa: version bump to 2.19.0 (diff)
downloadgentoo-35001519192bf033a769facfa49865b2f5baa36c.tar.gz
gentoo-35001519192bf033a769facfa49865b2f5baa36c.tar.bz2
gentoo-35001519192bf033a769facfa49865b2f5baa36c.zip
games-util/pyfa: remove old versions
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Zuber <a.zuber@gmx.ch> Closes: https://github.com/gentoo/gentoo/pull/15254 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/pyfa/Manifest2
-rw-r--r--games-util/pyfa/metadata.xml3
-rw-r--r--games-util/pyfa/pyfa-2.14.1.ebuild101
-rw-r--r--games-util/pyfa/pyfa-2.15.1-r1.ebuild100
4 files changed, 0 insertions, 206 deletions
diff --git a/games-util/pyfa/Manifest b/games-util/pyfa/Manifest
index c0921874eb7..e27f45155f2 100644
--- a/games-util/pyfa/Manifest
+++ b/games-util/pyfa/Manifest
@@ -1,4 +1,2 @@
-DIST pyfa-2.14.1.tar.gz 14452477 BLAKE2B e4c688cff14eecaa71f86fb9e22f6a585a3136a4bd7df65c8dd65ed82c2aa9e530210134daaba25251df92dc55a7e538474b39c1d54e4bcb1817eac17791d517 SHA512 d3d3219fa37f44c81d85165c7e780261e149b47db147417ea26edaff448484ce565607aded714a4f44ca23b8c1586c8597ace856020c4c319cea6d39f353b140
-DIST pyfa-2.15.1.tar.gz 14516568 BLAKE2B ba3b1170f35681ab33bece447b4bdf563c8f964037dc6b35cbd23360f7e36c61dd9074e34b5648c7a04b59ad192f5babd75ce2a935940a52e62de8cc174f7e5b SHA512 2d8fcb8608e31c135b8dac7239afe0a5acb0d32fba1291ce6ebafe093ef232c08f0aa42d172ebac5beefb7dba47aad9eb3833c679e3d02edc9cc056739c7538b
DIST pyfa-2.17.0.tar.gz 12348275 BLAKE2B fd670a6d34760285561ed07e82c3c54eb9a74cad732b24b89fab103fe8013608c18f27461bfac28a854df3ce7273fac1011752a8da2447b69432ad36709c08dd SHA512 d4af2c6a30deb8b205e5db55c25e1fa48dc74b964c9d85da69acca9bbd19764b77abc96ff42a2e99733d132253081a3e2c3de6ef787c162e392a9627ab62c529
DIST pyfa-2.19.0.tar.gz 11822419 BLAKE2B 7aaa9d8fc7de7ab9fb246bdf1dd61aa4aac6035d37cc6ecf9e32b03e67baada7d3dc765d02a7d9ed75f5933ccd76f92c4ae79c822c0562f8658dd1b52dfdba4d SHA512 5083f125cfd7f5d32e76029a836089cb79c5c6c93397712d37054518ed9bd77092d0c610cecdb1d0afce40753276431cdec72699ffc04088162158b55c04bac8
diff --git a/games-util/pyfa/metadata.xml b/games-util/pyfa/metadata.xml
index c556f4ff071..9633f2d9a69 100644
--- a/games-util/pyfa/metadata.xml
+++ b/games-util/pyfa/metadata.xml
@@ -15,9 +15,6 @@ fittings for the EVE Online SciFi MMORPG. It provides many advanced features
such as graphs and full calculations of any possible combination of modules,
fits, etc.
</longdescription>
- <use>
- <flag name="graph">Enable support for graphs</flag>
- </use>
<upstream>
<remote-id type="github">pyfa-org/Pyfa</remote-id>
</upstream>
diff --git a/games-util/pyfa/pyfa-2.14.1.ebuild b/games-util/pyfa/pyfa-2.14.1.ebuild
deleted file mode 100644
index 51e160ed66c..00000000000
--- a/games-util/pyfa/pyfa-2.14.1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,threads"
-
-inherit desktop eutils python-single-r1 xdg-utils
-
-DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
-HOMEPAGE="https://github.com/pyfa-org/Pyfa"
-
-LICENSE="GPL-3+ all-rights-reserved"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/Pyfa-${PV}
-fi
-IUSE="+graph"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="mirror bindist"
-
-DEPEND="
- $(python_gen_cond_dep '
- >=dev-python/cryptography-2.3[${PYTHON_MULTI_USEDEP}]
- >=dev-python/logbook-1.0.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_MULTI_USEDEP}]
- >=dev-python/sqlalchemy-1.3.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/wxpython-4.0.4[webkit,${PYTHON_MULTI_USEDEP}]
- ')"
-RDEPEND="${DEPEND}
- $(python_gen_cond_dep '
- >=dev-python/beautifulsoup-4.6.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/packaging-16.8[${PYTHON_MULTI_USEDEP}]
- dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/roman-2.0.0[${PYTHON_MULTI_USEDEP}]
- graph? (
- >=dev-python/matplotlib-2.0.0[wxwidgets,${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}] )
- ')
- ${PYTHON_DEPS}"
-BDEPEND="app-arch/zip"
-
-PATCHES=(
- # fix import path in the main script for systemwide installation
- "${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
- )
-
-src_prepare() {
- # get rid of CRLF line endings introduced in 1.1.10 so patches work
- edos2unix config.py pyfa.py gui/bitmap_loader.py service/settings.py
-
- default
-
- # make python recognize pyfa as a package
- touch __init__.py || die
-
- sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
- -e "s:%%EPREFIX%%:${EPREFIX}:" \
- "${FILESDIR}/configforced-1.15.1.py" > configforced.py || die
- sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
- pyfa.py > pyfa || die
-}
-
-src_install() {
- python_moduleinto ${PN}
- python_domodule eos gui service utils graphs
- python_domodule config*.py __init__.py version.yml configforced.py db_update.py
- python_doscript pyfa
-
- insinto /usr/share/${PN}
-
- einfo "Creating database ..."
- python ./db_update.py || die
- doins eve.db
-
- einfo "Compressing images ..."
- pushd imgs > /dev/null || die
- zip -r imgs.zip * || die "zip failed"
- doins imgs.zip
- popd > /dev/null || die
-
- dodoc README.md
- doicon -s 32 imgs/gui/pyfa.png
- newicon -s 64 imgs/gui/pyfa64.png pyfa.png
- domenu "${FILESDIR}/${PN}.desktop"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/games-util/pyfa/pyfa-2.15.1-r1.ebuild b/games-util/pyfa/pyfa-2.15.1-r1.ebuild
deleted file mode 100644
index 5c6b262d499..00000000000
--- a/games-util/pyfa/pyfa-2.15.1-r1.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,threads"
-
-inherit desktop eutils python-single-r1 xdg-utils
-
-DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
-HOMEPAGE="https://github.com/pyfa-org/Pyfa"
-
-LICENSE="GPL-3+ all-rights-reserved"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/Pyfa-${PV}
-fi
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="mirror bindist"
-
-DEPEND="
- $(python_gen_cond_dep '
- >=dev-python/cryptography-2.3[${PYTHON_MULTI_USEDEP}]
- >=dev-python/logbook-1.0.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_MULTI_USEDEP}]
- >=dev-python/sqlalchemy-1.3.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/wxpython-4.0.4[webkit,${PYTHON_MULTI_USEDEP}]
- ')
- ${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- $(python_gen_cond_dep '
- >=dev-python/beautifulsoup-4.6.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/packaging-16.8[${PYTHON_MULTI_USEDEP}]
- dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/roman-2.0.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/matplotlib-2.0.0[wxwidgets,${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- ')"
-BDEPEND="app-arch/zip"
-
-PATCHES=(
- # fix import path in the main script for systemwide installation
- "${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
- )
-
-src_prepare() {
- # get rid of CRLF line endings introduced in 1.1.10 so patches work
- edos2unix config.py pyfa.py gui/bitmap_loader.py service/settings.py
-
- default
-
- # make python recognize pyfa as a package
- touch __init__.py || die
-
- sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
- -e "s:%%EPREFIX%%:${EPREFIX}:" \
- "${FILESDIR}/configforced-1.15.1.py" > configforced.py || die
- sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
- pyfa.py > pyfa || die
-}
-
-src_install() {
- python_moduleinto ${PN}
- python_domodule eos gui service utils graphs
- python_domodule config*.py __init__.py version.yml configforced.py db_update.py
- python_doscript pyfa
-
- insinto /usr/share/${PN}
-
- einfo "Creating database ..."
- python ./db_update.py || die
- doins eve.db
-
- einfo "Compressing images ..."
- pushd imgs > /dev/null || die
- zip -r imgs.zip * || die "zip failed"
- doins imgs.zip
- popd > /dev/null || die
-
- dodoc README.md
- doicon -s 32 imgs/gui/pyfa.png
- newicon -s 64 imgs/gui/pyfa64.png pyfa.png
- domenu "${FILESDIR}/${PN}.desktop"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}