summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-08-03 23:24:31 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-08-03 23:24:31 +0100
commit7ba1cf2e897c0a7fef80f5e7bad4df18b8548507 (patch)
treec868ff575f711502c97ea62406d4f3fadaf09e22 /games-util
parentacct-user/man: Improved description. (diff)
downloadgentoo-7ba1cf2e897c0a7fef80f5e7bad4df18b8548507.tar.gz
gentoo-7ba1cf2e897c0a7fef80f5e7bad4df18b8548507.tar.bz2
gentoo-7ba1cf2e897c0a7fef80f5e7bad4df18b8548507.zip
games-util/mcrcon: Version bump to 0.6.1
Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/mcrcon/Manifest1
-rw-r--r--games-util/mcrcon/mcrcon-0.6.1.ebuild23
-rw-r--r--games-util/mcrcon/metadata.xml2
3 files changed, 25 insertions, 1 deletions
diff --git a/games-util/mcrcon/Manifest b/games-util/mcrcon/Manifest
index 122025299ea5..b50f011a7ff5 100644
--- a/games-util/mcrcon/Manifest
+++ b/games-util/mcrcon/Manifest
@@ -1 +1,2 @@
DIST mcrcon-0.0.5-src.zip 9748 BLAKE2B 27f209a51e0131f00a1d84b859301a5e0440c9fb857c9112c98c34749c9ab1dda3065d7d748e7a6385e034d3d349a9394cf547a42d2bf5ae3376276695c60994 SHA512 590da8007d630a9ff5332b5fda9e2498e949b4085e16fd00a4b1f693251980bc2d91736ea8ca7c649ee34b28484d165c8b5f45b1830e9fb661bec3a10af080d2
+DIST mcrcon-0.6.1.tar.gz 9891 BLAKE2B 41518ba654136b18930fb368600c1cd9d04d4b0043b9c741940ac43d8c0a4e07925350188852c09e0fac6219df363bd6d4f5c2511b4a95e1864a78c8537436e8 SHA512 db4a6f43a6ad0267ac0786dadb5eea8dd2ad4b7cd2509d5feba667f6130521b7a4870a8389d5e6706a26ecc5f29cb2a751c05d3e5deeee536d3e66f090db649f
diff --git a/games-util/mcrcon/mcrcon-0.6.1.ebuild b/games-util/mcrcon/mcrcon-0.6.1.ebuild
new file mode 100644
index 000000000000..4a5186fae685
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://github.com/Tiiffi/mcrcon"
+SRC_URI="https://github.com/Tiiffi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -std=gnu99 -Wall -Wextra -Wpedantic"
+}
+
+src_install() {
+ emake install PREFIX="${ED}/usr"
+}
diff --git a/games-util/mcrcon/metadata.xml b/games-util/mcrcon/metadata.xml
index e7f8f4b0d06d..fb1c568c641f 100644
--- a/games-util/mcrcon/metadata.xml
+++ b/games-util/mcrcon/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<longdescription>mcrcon is an IPv6 compliant Minecraft rcon client with Bukkit coloring support. It is well suited for remote administration and to be used as part of automated server maintenance scripts. Does not trigger the "IO: Broken pipe" or "IO: Connection reset" spam bug on the server side.</longdescription>
<upstream>
- <remote-id type="sourceforge">mcrcon</remote-id>
+ <remote-id type="github">Tiiffi/mcrcon</remote-id>
</upstream>
</pkgmetadata>