summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-01-08 19:52:39 +0200
committerMart Raudsepp <leio@gentoo.org>2018-01-08 19:53:55 +0200
commite1643c062300cb1771eb0b0804aed40e73170901 (patch)
treec66316a819401be3e2e9a2a7721a891800f056a8 /gnome-base/gnome-control-center
parentapp-admin/puppet-agent: 5.3.3-r1 for bug 606918 (libreadline dep) (diff)
downloadgentoo-e1643c062300cb1771eb0b0804aed40e73170901.tar.gz
gentoo-e1643c062300cb1771eb0b0804aed40e73170901.tar.bz2
gentoo-e1643c062300cb1771eb0b0804aed40e73170901.zip
gnome-base/gnome-control-center: guarantee a working Night Light functionality
Night Light isn't behind USE=colord (not optional), but requires gnome-settings-daemon[colord], so unconditionally depend on that. Raise cups dep to 1.7 while here, as it uses an enum constant introduced there and we don't backport the fix for that from gnome-3-24 branch. No practical difference, as there is no such old version in-tree anymore. Closes: https://bugs.gentoo.org/619298 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'gnome-base/gnome-control-center')
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-3.24.3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnome-base/gnome-control-center/gnome-control-center-3.24.3.ebuild b/gnome-base/gnome-control-center/gnome-control-center-3.24.3.ebuild
index b7fe8aa31c0..4f53c91e092 100644
--- a/gnome-base/gnome-control-center/gnome-control-center-3.24.3.ebuild
+++ b/gnome-base/gnome-control-center/gnome-control-center-3.24.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,7 +24,7 @@ QA_CONFIGURE_OPTIONS=".*"
# kerberos unfortunately means mit-krb5; build fails with heimdal
# udev could be made optional, only conditions gsd-device-panel
# (mouse, keyboards, touchscreen, etc)
-# display panel requires colord
+# display panel requires colord and gnome-settings-daemon[colord]
# printer panel requires cups and smbclient (the latter is not patch yet to be separately optional)
COMMON_DEPEND="
>=dev-libs/glib-2.44.0:2[dbus]
@@ -32,7 +32,7 @@ COMMON_DEPEND="
>=x11-libs/gtk+-3.22.0:3[X,wayland?]
>=gnome-base/gsettings-desktop-schemas-3.21.4
>=gnome-base/gnome-desktop-3.21.2:3=
- >=gnome-base/gnome-settings-daemon-3.23.90[colord?,policykit]
+ >=gnome-base/gnome-settings-daemon-3.23.90[colord,policykit]
>=x11-misc/colord-0.1.34:0=
>=dev-libs/libpwquality-1.2.2
@@ -59,7 +59,7 @@ COMMON_DEPEND="
>=x11-misc/colord-0.1.34:0=
>=x11-libs/colord-gtk-0.1.24 )
cups? (
- >=net-print/cups-1.4[dbus]
+ >=net-print/cups-1.7[dbus]
>=net-fs/samba-4.0.0[client]
)
gnome-online-accounts? (