summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2017-10-01 15:33:12 +0200
committerMart Raudsepp <leio@gentoo.org>2017-10-31 00:34:08 +0200
commit03ae679c40b695407e92ea381a6be0f42b93f73d (patch)
tree69c490c227184cec8902686a3da438d70fdadcaa /gnome-base/gnome-settings-daemon
parentapp-text/rarian: remove unused patch (diff)
downloadgentoo-03ae679c40b695407e92ea381a6be0f42b93f73d.tar.gz
gentoo-03ae679c40b695407e92ea381a6be0f42b93f73d.tar.bz2
gentoo-03ae679c40b695407e92ea381a6be0f42b93f73d.zip
gnome-base/gnome-settings-daemon: remove unused patch
Diffstat (limited to 'gnome-base/gnome-settings-daemon')
-rw-r--r--gnome-base/gnome-settings-daemon/files/3.24.2-optional.patch145
1 files changed, 0 insertions, 145 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/3.24.2-optional.patch b/gnome-base/gnome-settings-daemon/files/3.24.2-optional.patch
deleted file mode 100644
index 64c47a92e3f..00000000000
--- a/gnome-base/gnome-settings-daemon/files/3.24.2-optional.patch
+++ /dev/null
@@ -1,145 +0,0 @@
-From 22f6a45b665e604f874e82a817d45bb976d8c5ae Mon Sep 17 00:00:00 2001
-From: Timo Tambet <ttambet@gmail.com>
-Date: Sat, 25 Feb 2017 14:48:19 +0200
-Subject: [PATCH 1/1] [PATCH] Make colord and wacom support optional
-
----
- configure.ac | 56 +++++++++++++++++++++++++++++++----------------
- plugins/Makefile.am | 9 ++++++--
- plugins/dummy/Makefile.am | 5 ++++-
- 3 files changed, 48 insertions(+), 22 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 0d169c8f..792195aa 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -158,13 +158,23 @@ PKG_CHECK_MODULES(CLIPBOARD,
- gtk+-x11-3.0
- x11)
-
--PKG_CHECK_MODULES(COLOR,
-- colord >= 1.0.2
-- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
-- libcanberra-gtk3
-- libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION
-- lcms2 >= $LCMS_REQUIRED_VERSION
-- libnotify)
-+AC_ARG_ENABLE([color],
-+ AS_HELP_STRING([--disable-color],
-+ [turn off color plugin]),
-+ [],
-+ [enable_color=yes])
-+
-+AS_IF([test "$enable_color" = "yes"],
-+ [PKG_CHECK_MODULES(COLOR,
-+ colord >= 1.0.2
-+ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
-+ libcanberra-gtk3
-+ libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION
-+ lcms2 >= $LCMS_REQUIRED_VERSION
-+ libnotify)
-+ AC_DEFINE(HAVE_COLOR, 1, [Define if color plugin is enabled])
-+ ])
-+AM_CONDITIONAL(BUILD_COLOR, test "x$enable_color" = "xyes")
-
- PKG_CHECK_MODULES(DATETIME,
- libnotify >= $LIBNOTIFY_REQUIRED_VERSION
-@@ -268,23 +278,31 @@ case $host_os in
- if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
- have_wacom=no
- else
-- if test x$enable_gudev != xno; then
-- LIBWACOM_PKG="libwacom >= $LIBWACOM_REQUIRED_VERSION"
-- PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
-- PKG_CHECK_MODULES(WACOM, [gtk+-3.0 pango >= $PANGO_REQUIRED_VERSION])
-- PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
-- else
-+ have_wacom=no
-+ AS_IF([test "$enable_gudev" != "no"],
-+ [AC_ARG_ENABLE([wacom],
-+ AS_HELP_STRING([--disable-wacom],
-+ [turn off wacom plugin]),
-+ [],
-+ [enable_wacom=no]) dnl Default value
-+ AS_IF([test "$enable_wacom" = "xyes"],
-+ [
-+ PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
-+ PKG_CHECK_MODULES(WACOM, [gtk+-3.0, pango >= $PANGO_REQUIRED_VERSION])
-+ PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
-+ have_wacom=yes
-+ AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
-+ ])
-+ ], [
- AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
-- fi
-- AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
-- have_wacom=yes
-+ ])
- fi
- ;;
- *)
-- have_wacom=no
-- ;;
-+ have_wacom=no
-+ ;;
- esac
--AM_CONDITIONAL(HAVE_WACOM, test x$have_wacom = xyes)
-+AM_CONDITIONAL(BUILD_WACOM, test x$have_wacom = xyes)
-
- dnl ---------------------------------------------------------------------------
- dnl - common
-diff --git a/plugins/Makefile.am b/plugins/Makefile.am
-index 9324b406..ee78d6d0 100644
---- a/plugins/Makefile.am
-+++ b/plugins/Makefile.am
-@@ -4,7 +4,6 @@ enabled_plugins = \
- a11y-keyboard \
- a11y-settings \
- clipboard \
-- color \
- datetime \
- dummy \
- power \
-@@ -22,13 +21,19 @@ enabled_plugins = \
-
- disabled_plugins = $(NULL)
-
-+if BUILD_COLOR
-+enabled_plugins += color
-+else
-+disabled_plugins += color
-+endif
-+
- if SMARTCARD_SUPPORT
- enabled_plugins += smartcard
- else
- disabled_plugins += smartcard
- endif
-
--if HAVE_WACOM
-+if BUILD_WACOM
- enabled_plugins += wacom
- else
- disabled_plugins += wacom
-diff --git a/plugins/dummy/Makefile.am b/plugins/dummy/Makefile.am
-index cb5856cf..06ac595a 100644
---- a/plugins/dummy/Makefile.am
-+++ b/plugins/dummy/Makefile.am
-@@ -22,10 +22,13 @@ gsd_dummy_LDADD = $(DUMMY_LIBS) $(top_builddir)/gnome-settings-daemon/libgsd.la
- desktopdir = $(sysconfdir)/xdg/autostart
-
- desktop_DATA =
-+if !BUILD_COLOR
-+desktop_DATA += org.gnome.SettingsDaemon.Color.desktop
-+endif
- if !SMARTCARD_SUPPORT
- desktop_DATA += org.gnome.SettingsDaemon.Smartcard.desktop
- endif
--if !HAVE_WACOM
-+if !BUILD_WACOM
- desktop_DATA += org.gnome.SettingsDaemon.Wacom.desktop
- endif
- if !BUILD_PRINT_NOTIFICATIONS
---
-2.11.1
-