summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2019-02-07 23:28:30 +0100
committerRémi Cardona <remi@gentoo.org>2019-02-07 23:30:37 +0100
commitcba0b9701371df6fc3c8b5767aca839f312feaae (patch)
tree80b50742121644cf27fef56eae3caa4a831a3ee5 /gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild
parentqt5-build.eclass: move the 's/optimize_full//' sed where it belongs (diff)
downloadgentoo-cba0b9701371df6fc3c8b5767aca839f312feaae.tar.gz
gentoo-cba0b9701371df6fc3c8b5767aca839f312feaae.tar.bz2
gentoo-cba0b9701371df6fc3c8b5767aca839f312feaae.zip
gnome-base/libgnomekbd: bump to 3.26.1
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Rémi Cardona <remi@gentoo.org>
Diffstat (limited to 'gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild')
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild b/gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild
new file mode 100644
index 000000000000..778e492f11c0
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-3.26.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="https://www.gnome.org"
+
+LICENSE="LGPL-2+"
+SLOT="0/8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.91.7:3[X,introspection?]
+ >=x11-libs/libxklavier-5.2[introspection?]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}