summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-17 00:07:10 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-17 00:32:27 +0300
commit1c36091847155f34590a78105b11d69e29b1c118 (patch)
tree7625a74f1495e9eb256debfc4e7854c256af3cbc /gnome-base
parentgnome-base/libgnomeprintui: Remove last-rited package (diff)
downloadgentoo-1c36091847155f34590a78105b11d69e29b1c118.tar.gz
gentoo-1c36091847155f34590a78105b11d69e29b1c118.tar.bz2
gentoo-1c36091847155f34590a78105b11d69e29b1c118.zip
gnome-base/libgnomeprint: Remove last-rited package
Closes: https://bugs.gentoo.org/352952
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnomeprint/Manifest1
-rw-r--r--gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-bison3.patch39
-rw-r--r--gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-cups-config.patch39
-rw-r--r--gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch91
-rw-r--r--gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-stdio-include.patch9
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild72
-rw-r--r--gnome-base/libgnomeprint/metadata.xml8
7 files changed, 0 insertions, 259 deletions
diff --git a/gnome-base/libgnomeprint/Manifest b/gnome-base/libgnomeprint/Manifest
deleted file mode 100644
index f359c322454..00000000000
--- a/gnome-base/libgnomeprint/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libgnomeprint-2.18.8.tar.bz2 880489 BLAKE2B e706e227c51b4be17246a86c59a29ec9129ea5dce7a073785debc29d04b2a13e71c731085088242bf4bc7946f7862f8d4c8c67b09afc05dc3e59d6809635a79d SHA512 eca4f118e918f8db04332c3c6df5370ee45497057b44747457b05f0517c55b38271b24cdf7493b8ba24875b2d53d99b5e64d5d63a04cd7fd895cb02ae1606469
diff --git a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-bison3.patch b/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-bison3.patch
deleted file mode 100644
index d9fbbdd84fb..00000000000
--- a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-bison3.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-http://git.pld-linux.org/gitweb.cgi?p=packages/libgnomeprint.git;a=blob;f=bison3.patch
-
---- libgnomeprint-2.18.8/libgnomeprint/grammar.y.orig 2010-02-09 13:32:51.000000000 +0100
-+++ libgnomeprint-2.18.8/libgnomeprint/grammar.y 2013-11-03 21:44:59.859877696 +0100
-@@ -6,8 +6,6 @@
- #include <libgnomeprint/types.h>
- #include <libgnomeprint/gnome-print-filter.h>
-
--#define YYPARSE_PARAM graph
--
- static void
- set_value_from_string (GParamSpec *pspec, GValue *v, const gchar *s)
- {
-@@ -99,7 +97,7 @@
- }
-
- static int yylex (void *lvalp);
--static int yyerror (const char *s);
-+static int yyerror (graph_t *g, const char *s);
- %}
-
- %union {
-@@ -117,6 +115,7 @@
- %type <p> pool
-
- %pure_parser
-+%parse-param { graph_t *graph }
-
- %start graph
- %%
-@@ -185,7 +184,7 @@
- %%
-
- static int
--yyerror (const char *s)
-+yyerror (graph_t *g, const char *s)
- {
- return -1;
- }
diff --git a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-cups-config.patch b/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-cups-config.patch
deleted file mode 100644
index 999c6f07520..00000000000
--- a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-cups-config.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From ffbc68cc8518c7e7263a42d4284b749b40c5e871 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 29 Jun 2014 10:47:41 +0200
-Subject: [PATCH] Use AC_PATH_TOOL to find proper cups-config.
-
----
- configure.in | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index 729278d..186fabf 100644
---- a/configure.in
-+++ b/configure.in
-@@ -223,17 +223,18 @@ AC_ARG_WITH(cups,
- )
- if test "x$try_cups" = "xyes"; then
- PKG_CHECK_MODULES(CUPS, "gmodule-2.0")
-+ AC_PATH_TOOL(CUPS_CONFIG, cups-config)
- AC_MSG_CHECKING(for CUPS libraries version >= 1.1.20)
-- if cups-config --version --libs > /dev/null 2>&1; then
-- verstxt=`cups-config --version`
-+ if $CUPS_CONFIG --version --libs > /dev/null 2>&1; then
-+ verstxt=`$CUPS_CONFIG --version`
- vers=`echo "$verstxt" | \
- awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
- if test "$vers" -lt 1001020; then
- AC_MSG_RESULT(Cups found but the version found is less than 1.1.20)
- cups_msg="Version requirement not satisfied"
- else
-- CUPS_LIBS="$CUPS_LIBS `cups-config --ldflags` `cups-config --libs`"
-- CUPS_CFLAGS="$CUPS_CFLAGS `cups-config --cflags`"
-+ CUPS_LIBS="$CUPS_LIBS `$CUPS_CONFIG --ldflags` `$CUPS_CONFIG --libs`"
-+ CUPS_CFLAGS="$CUPS_CFLAGS `$CUPS_CONFIG --cflags`"
- AC_MSG_RESULT(Found version $verstxt)
- fi
-
---
-2.0.0
-
diff --git a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch b/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch
deleted file mode 100644
index 1a54e9be5b6..00000000000
--- a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-freetype-2.5.1.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From e848ee98108ab8c5b12e2167b041b274b4bede83 Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Thu, 8 Oct 2015 11:06:44 +0200
-Subject: [PATCH] Update freetype includes to work with >=freetype-2.5.1
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- configure.in | 22 +++-------------------
- libgnomeprint/gnome-font-face.c | 3 ++-
- libgnomeprint/gnome-print-gdi.c | 2 +-
- libgnomeprint/gnome-rfont.c | 4 ++--
- 4 files changed, 8 insertions(+), 23 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index c15bb69..aebe591 100644
---- a/configure.in
-+++ b/configure.in
-@@ -162,25 +162,9 @@ LDFLAGS="$LDFLAGS $LIBM"
- dnl =================================
- dnl Checking for freetype2
- dnl =================================
--FREETYPE_LIBS=
--FREETYPE_CFLAGS=
--AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
--if test "x$FREETYPE_CONFIG" = "xno" ; then
-- AC_MSG_ERROR(You need FreeType2 (freetype-devel v 2.x package) for this version of libgnomeprint)
--else
-- FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags`
-- FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
--fi
--
--libgnomeprint_save_ldflags=$LDFLAGS
--LDFLAGS="$LDFLAGS $FREETYPE_LIBS"
--
--freetype_version=false
--AC_MSG_NOTICE([checking for sufficiently new FreeType (at least 2.0.5)])
--AC_CHECK_LIB(freetype, FT_Get_Postscript_Name,:,[
-- AC_MSG_ERROR(You need FreeType2 (freetype-devel 2.0.5 or greater package) for this version of libgnomeprint)])
--
--LDFLAGS=$libgnomeprint_save_ldflags
-+dnl "freetype2 >= 17" means freetype-2.5.1
-+PKG_CHECK_MODULES(FREETYPE, freetype2 >= 17, ,
-+ [PKG_CHECK_MODULES(FREETYPE, freetype2, [FREETYPE_CFLAGS="$FREETYPE_CFLAGS -I`$PKG_CONFIG --variable=includedir freetype2`/freetype2/freetype"])])
-
- dnl =================================
- dnl END: Checking for freetype2
-diff --git a/libgnomeprint/gnome-font-face.c b/libgnomeprint/gnome-font-face.c
-index 0447377..23794a8 100644
---- a/libgnomeprint/gnome-font-face.c
-+++ b/libgnomeprint/gnome-font-face.c
-@@ -36,7 +36,8 @@
- #include <stdarg.h>
- #include <locale.h>
-
--#include <freetype/ftoutln.h>
-+#include <ft2build.h>
-+#include FT_OUTLINE_H
-
- #include <libgnomeprint/gnome-print-private.h>
- #include <libgnomeprint/gnome-font-private.h>
-diff --git a/libgnomeprint/gnome-print-gdi.c b/libgnomeprint/gnome-print-gdi.c
-index f89a8e8..7755673 100755
---- a/libgnomeprint/gnome-print-gdi.c
-+++ b/libgnomeprint/gnome-print-gdi.c
-@@ -36,7 +36,7 @@
- #include <libgnomeprint/gp-gc-private.h>
-
- #include <ft2build.h>
--#include <freetype/freetype.h>
-+#include FT_FREETYPE_H
-
- #define WIN32_LEAN_AND_MEAN
- #include <windows.h>
-diff --git a/libgnomeprint/gnome-rfont.c b/libgnomeprint/gnome-rfont.c
-index 55ec261..a71bbda 100644
---- a/libgnomeprint/gnome-rfont.c
-+++ b/libgnomeprint/gnome-rfont.c
-@@ -28,8 +28,8 @@
-
- #include <ft2build.h>
- #include FT_FREETYPE_H
--#include <freetype/ftglyph.h>
--#include <freetype/ftbbox.h>
-+#include FT_GLYPH_H
-+#include FT_BBOX_H
- #include <libart_lgpl/art_misc.h>
- #include <libart_lgpl/art_affine.h>
- #include <libart_lgpl/art_vpath.h>
---
-2.6.1
-
diff --git a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-stdio-include.patch b/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-stdio-include.patch
deleted file mode 100644
index dd9195434e8..00000000000
--- a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-stdio-include.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/libgnomeprint/modules/cups/gnome-print-cups-transport.c
-+++ b/libgnomeprint/modules/cups/gnome-print-cups-transport.c
-@@ -34,6 +34,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <stdio.h>
- #include <unistd.h>
- #include <locale.h>
diff --git a/gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild b/gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild
deleted file mode 100644
index 599e35a3daa..00000000000
--- a/gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME_TARBALL_SUFFIX="bz2"
-
-inherit autotools eutils gnome2 multilib-minimal
-
-DESCRIPTION="Printer handling for Gnome"
-HOMEPAGE="https://www.gnome.org/"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="2.2"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
-IUSE="cups doc"
-
-RDEPEND=">=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}]
- >=media-libs/libart_lgpl-2.3.21-r2[${MULTILIB_USEDEP}]
- >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}]
- >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
- >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
- >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- cups? (
- >=net-print/cups-1.7.1-r1[${MULTILIB_USEDEP}]
- >=net-print/libgnomecups-0.2.3-r3[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- >=dev-util/intltool-0.35
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- sys-devel/flex
- sys-devel/bison
- doc? (
- ~app-text/docbook-xml-dtd-4.1.2
- >=dev-util/gtk-doc-0.9 )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-stdio-include.patch \
- "${FILESDIR}"/${P}-freetype-2.5.1.patch \
- "${FILESDIR}"/${P}-bison3.patch \
- "${FILESDIR}"/${P}-cups-config.patch
- eautoreconf
- gnome2_src_prepare
-
- # Drop DEPRECATED flags, bug #384807
- sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED::g' \
- configure.in configure || die
- sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
- libgnomeprint/ttsubset/Makefile.am \
- libgnomeprint/ttsubset/Makefile.in || die
-}
-
-multilib_src_configure() {
- # Disable papi support until papi is in portage; avoids automagic
- # dependencies on an untracked library.
-
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- $(use_with cups) \
- --without-papi \
- --disable-static
-}
-
-multilib_src_install() {
- gnome2_src_install
-}
-
-multilib_src_install_all() {
- DOCS="AUTHORS BUGS ChangeLog* NEWS README"
- einstalldocs
-}
diff --git a/gnome-base/libgnomeprint/metadata.xml b/gnome-base/libgnomeprint/metadata.xml
deleted file mode 100644
index 39980802b1d..00000000000
--- a/gnome-base/libgnomeprint/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>