summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2017-11-27 22:22:08 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2017-11-27 22:22:22 +0100
commitacf9a86375dd07521bf6c8f706c7c9534f37a9a5 (patch)
tree023f663590d4e6339d9f663c1d4287532c1bfcca /gnome-extra/cinnamon-session/files
parentdev-libs/openssl: stable 1.0.2m for sparc, bug #636264 (thanks to Rolf Eike B... (diff)
downloadgentoo-acf9a86375dd07521bf6c8f706c7c9534f37a9a5.tar.gz
gentoo-acf9a86375dd07521bf6c8f706c7c9534f37a9a5.tar.bz2
gentoo-acf9a86375dd07521bf6c8f706c7c9534f37a9a5.zip
gnome-extra/cinnamon-session: Add elogind
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'gnome-extra/cinnamon-session/files')
-rw-r--r--gnome-extra/cinnamon-session/files/cinnamon-session-3.6.1-elogind.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-session/files/cinnamon-session-3.6.1-elogind.patch b/gnome-extra/cinnamon-session/files/cinnamon-session-3.6.1-elogind.patch
new file mode 100644
index 000000000000..b35ce9e55bfd
--- /dev/null
+++ b/gnome-extra/cinnamon-session/files/cinnamon-session-3.6.1-elogind.patch
@@ -0,0 +1,65 @@
+diff --git a/cinnamon-session/Makefile.am b/cinnamon-session/Makefile.am
+index 789d47d..d8093d4 100644
+--- a/cinnamon-session/Makefile.am
++++ b/cinnamon-session/Makefile.am
+@@ -71,6 +71,7 @@ cinnamon_session_CPPFLAGS = \
+ $(XEXT_CFLAGS) \
+ $(GCONF_CFLAGS) \
+ $(LOGIND_CFLAGS) \
++ $(ELOGIND_CFLAGS) \
+ -I$(top_srcdir)/egg \
+ -DLOCALE_DIR=\""$(datadir)/locale"\" \
+ -DDATA_DIR=\""$(datadir)/cinnamon-session"\" \
+@@ -91,6 +92,7 @@ cinnamon_session_LDADD = \
+ $(UPOWER_LIBS) \
+ $(GCONF_LIBS) \
+ $(LOGIND_LIBS) \
++ $(ELOGIND_LIBS) \
+ $(EXECINFO_LIBS)
+
+ libcsmutil_la_SOURCES = \
+diff --git a/cinnamon-session/csm-systemd.c b/cinnamon-session/csm-systemd.c
+index cef991c..dc2aa2e 100644
+--- a/cinnamon-session/csm-systemd.c
++++ b/cinnamon-session/csm-systemd.c
+@@ -32,7 +32,11 @@
+ #include <sys/types.h>
+ #include <pwd.h>
+
++#ifdef HAVE_ELOGIND
++#include <elogind/sd-login.h>
++#else
+ #include <systemd/sd-login.h>
++#endif
+
+ #include <glib.h>
+ #include <glib-object.h>
+diff --git a/configure.ac b/configure.ac
+index 38db5a3..8dafc6a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -113,15 +113,23 @@ AC_ARG_ENABLE([logind],
+
+ have_logind=no
+ if test x$enable_logind != xno ; then
+- PKG_CHECK_MODULES(LOGIND, [gio-unix-2.0 libsystemd >= 183], [have_logind=yes], [have_logind=no])
++ PKG_CHECK_MODULES(LOGIND, [gio-unix-2.0], [have_logind=yes], [have_logind=no])
+ fi
+
+ if test x$have_logind = xyes; then
+ AC_DEFINE(HAVE_LOGIND, 1, [Define if logind is supported])
+ fi
+
++have_elogind=no
++PKG_CHECK_MODULES(ELOGIND, [libelogind], [have_elogind=yes], [have_elogind=no])
++if test x$have_elogind = xyes; then
++ AC_DEFINE(HAVE_ELOGIND, 1, [Define if logind is supported])
++fi
++
+ AC_SUBST(LOGIND_CFLAGS)
+ AC_SUBST(LOGIND_LIBS)
++AC_SUBST(ELOGIND_CFLAGS)
++AC_SUBST(ELOGIND_LIBS)
+
+ dnl ====================================================================
+ dnl Option to disable DBus user session support.