summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2018-07-04 12:30:04 +0200
committerKristian Fiskerstrand <k_f@gentoo.org>2018-07-31 10:34:29 +0200
commit38cdad5df60731d57bfd02d4413fa8e9071e5e9c (patch)
treeed3898c132a546457025dcd07495d2ab2d385e63 /gnome-extra/cinnamon
parentgnome-extra/nemo: New upstream version 3.8.3 (diff)
downloadgentoo-38cdad5df60731d57bfd02d4413fa8e9071e5e9c.tar.gz
gentoo-38cdad5df60731d57bfd02d4413fa8e9071e5e9c.tar.bz2
gentoo-38cdad5df60731d57bfd02d4413fa8e9071e5e9c.zip
gnome-extra/cinnamon: New upstream version 3.8.8
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'gnome-extra/cinnamon')
-rw-r--r--gnome-extra/cinnamon/Manifest1
-rw-r--r--gnome-extra/cinnamon/cinnamon-3.8.8.ebuild207
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-3.8.0-gnome-background-compatibility.patch25
3 files changed, 233 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon/Manifest b/gnome-extra/cinnamon/Manifest
index d5fec8d07890..d50a6456091e 100644
--- a/gnome-extra/cinnamon/Manifest
+++ b/gnome-extra/cinnamon/Manifest
@@ -1 +1,2 @@
DIST cinnamon-3.6.6.tar.gz 2211080 BLAKE2B a5be448413532b6cc84c77d17e56739a8c2f3c26f21fac3fcdcaeda127a00e1a8f7d623964c4040f77624da06795eb607491aef55bf31fcb291b074ee75930f9 SHA512 9bd153508458bae2f99a451620fe5e80e45cae0e10cf113b07ca2c0a76cd16e84c4a6d743c659ef41ab91066df025f78a0ea2005a3d34ddd065fe88f358b6642
+DIST cinnamon-3.8.8.tar.gz 2234388 BLAKE2B edc27a670d788673602536f960e2859f6cc15a52ebd12cd741821c4455664ca6bfc6f2b2e3282a0797b15bf93a33208f4f4458df7b2cbe17e50d90412811265c SHA512 5f8acf181fde8d9156ef8767f97b24e207f6c44975e5ef97e812fcdd3b2d5ce4c921297b679ad1ade6fa8e4f9c544b74143f4d925d022cc95d6c71561ab40b53
diff --git a/gnome-extra/cinnamon/cinnamon-3.8.8.ebuild b/gnome-extra/cinnamon/cinnamon-3.8.8.ebuild
new file mode 100644
index 000000000000..26e4c59984c4
--- /dev/null
+++ b/gnome-extra/cinnamon/cinnamon-3.8.8.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit autotools eutils flag-o-matic gnome2 multilib pax-utils python-r1
+
+DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
+HOMEPAGE="http://developer.linuxmint.com/"
+
+MY_PV="${PV/_p/-UP}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/linuxmint/Cinnamon/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+IUSE="+nls"
+
+# We need *both* python 2.x and 3.x
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ || ( $(python_gen_useflags 'python2*') )
+ || ( $(python_gen_useflags 'python3*') )
+"
+
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ app-accessibility/at-spi2-atk:2
+ app-misc/ca-certificates
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.35.0:2[dbus]
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=dev-libs/json-glib-0.13.2
+ >=dev-libs/libcroco-0.6.2:0.6
+ dev-libs/libxml2:2
+ gnome-base/gconf:2[introspection]
+ gnome-base/librsvg
+ >=gnome-extra/cinnamon-desktop-3.6:0=[introspection]
+ >=gnome-extra/cinnamon-menus-3.6[introspection]
+ >=gnome-extra/cjs-3.8.0
+ >=media-libs/clutter-1.10:1.0[introspection]
+ media-libs/cogl:1.0=[introspection]
+ >=gnome-base/gsettings-desktop-schemas-2.91.91
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ net-libs/libsoup:2.4[introspection]
+ >=sys-auth/polkit-0.100[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.12.0:3[introspection]
+ x11-libs/pango[introspection]
+ >=x11-libs/startup-notification-0.11
+ x11-libs/libX11
+ >=x11-libs/libXfixes-5.0
+ >=x11-wm/muffin-3.8.0[introspection]
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Each block:
+# 2. Introspection stuff + dconf needed via imports.gi.*
+# 3. gnome-session is needed for gnome-session-quit
+# 4. Control shell settings
+# 5. accountsservice is needed for GdmUserManager (0.6.14 needed for fast
+# user switching with gdm-3.1.x)
+# 6. caribou needed for on-screen keyboard
+# 7. xdg-utils needed for xdg-open, used by extension tool
+# 8. gconf-python, imaging, lxml needed for cinnamon-settings
+# 9. gnome-icon-theme-symbolic needed for various icons
+# 10. pygobject needed for menu editor
+# 11. nemo - default file manager, tightly integrated with cinnamon
+# 12. polkit-gnome - explicitly autostarted by us
+# TODO(lxnay): fix error: libgnome-desktop/gnome-rr-labeler.h: No such file or directory
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/dconf-0.4.1
+ >=gnome-base/libgnomekbd-2.91.4[introspection]
+ || ( sys-power/upower[introspection] sys-power/upower-pm-utils[introspection] )
+
+ >=gnome-extra/cinnamon-session-3.8
+ >=gnome-extra/cinnamon-settings-daemon-3.8
+
+ >=app-accessibility/caribou-0.3
+
+ x11-misc/xdg-utils
+ x11-libs/xapps[introspection]
+
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/gconf-python:2[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pycairo[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pyinotify[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pypam[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]' 'python2*')
+
+ x11-themes/gnome-themes-standard
+ x11-themes/adwaita-icon-theme
+
+ >=gnome-extra/nemo-3.8
+ >=gnome-extra/cinnamon-control-center-3.8
+ >=gnome-extra/cinnamon-screensaver-3.8
+
+ gnome-extra/polkit-gnome
+
+ nls? ( >=gnome-extra/cinnamon-translations-3.8 )
+"
+DEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep 'dev-python/polib[${PYTHON_USEDEP}]' 'python2*')
+ dev-util/gtk-doc
+ >=dev-util/intltool-0.4
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ gnome-base/gnome-common
+ !!=dev-lang/spidermonkey-1.8.2*
+"
+# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
+# https://bugs.gentoo.org/show_bug.cgi?id=360413
+
+S="${WORKDIR}/Cinnamon-${PV}"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ # Fix backgrounds path as cinnamon doesn't provide them
+ # https://github.com/linuxmint/Cinnamon/issues/3575
+ eapply "${FILESDIR}"/${PN}-3.8.0-gnome-background-compatibility.patch
+
+ # Use wheel group instead of sudo (from Fedora/Arch)
+ # https://github.com/linuxmint/Cinnamon/issues/3576
+ eapply "${FILESDIR}"/${PN}-3.6.6-wheel-sudo.patch
+
+ # Use pkexec instead of gksu (from Arch)
+ # https://github.com/linuxmint/Cinnamon/issues/3565
+ sed -i 's/gksu/pkexec/' files/usr/bin/cinnamon-settings-users || die
+
+ # Add polkit agent to required components (from Fedora/Arch), bug #523958
+ # https://github.com/linuxmint/Cinnamon/issues/3579
+ sed -i 's/RequiredComponents=\(.*\)$/RequiredComponents=\1polkit-gnome-authentication-agent-1;/' \
+ files/usr/share/cinnamon-session/sessions/cinnamon*.session || die
+
+ # python 2-and-3 shebang fixing craziness
+ local p
+ python_setup 'python3*'
+ for p in $(grep -rl '#!.*python3'); do
+ python_fix_shebang "${p}"
+ done
+
+ python_setup 'python2*'
+ for p in $(grep -rl '#!.*python[^3]'); do
+ python_fix_shebang "${p}"
+ done
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-ca-certificates="${EPREFIX}/etc/ssl/certs/ca-certificates.crt" \
+ BROWSER_PLUGIN_DIR="${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED}"usr/$(get_libdir)/cinnamon-*
+
+ # Required for gnome-shell on hardened/PaX, bug #398941
+ pax-mark mr "${ED}usr/bin/cinnamon"
+
+ # Doesn't exist on Gentoo, causing this to be a dead symlink
+ rm -f "${ED}etc/xdg/menus/cinnamon-applications-merged" || die
+
+ # Ensure authentication-agent is started, bug #523958
+ # https://github.com/linuxmint/Cinnamon/issues/3579
+ insinto /etc/xdg/autostart/
+ doins "${FILESDIR}"/polkit-cinnamon-authentication-agent-1.desktop
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version 'media-libs/gst-plugins-good:1.0' || \
+ ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
+ ewarn "To make use of Cinnamon's built-in screen recording utility,"
+ ewarn "you need to either install media-libs/gst-plugins-good:1.0"
+ ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
+ ewarn "org.cinnamon.recorder/pipeline to what you want to use."
+ fi
+
+ if ! has_version ">=x11-base/xorg-server-1.11"; then
+ ewarn "If you use multiple screens, it is highly recommended that you"
+ ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
+ ewarn "pointer barriers which will make it easier to use hot corners."
+ fi
+
+ if has_version "<x11-drivers/ati-drivers-12"; then
+ ewarn "Cinnamon has been reported to show graphical corruption under"
+ ewarn "x11-drivers/ati-drivers-11.*; you may want to switch to"
+ ewarn "open-source drivers."
+ fi
+}
diff --git a/gnome-extra/cinnamon/files/cinnamon-3.8.0-gnome-background-compatibility.patch b/gnome-extra/cinnamon/files/cinnamon-3.8.0-gnome-background-compatibility.patch
new file mode 100644
index 000000000000..6f802fee6585
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-3.8.0-gnome-background-compatibility.patch
@@ -0,0 +1,25 @@
+From 21710409c0ed8acfbad98131d1664006d32181bf Mon Sep 17 00:00:00 2001
+From: Kristian Fiskerstrand <kf@sumptuouscapital.com>
+Date: Sat, 30 Jun 2018 20:24:55 +0200
+Subject: [PATCH] gnome-background-compatibility
+
+---
+ files/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/files/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py b/files/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py
+index 6e279ed..ec47983 100755
+--- a/files/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py
++++ b/files/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py
+@@ -268,7 +268,7 @@ class Module:
+ def get_system_backgrounds(self):
+ picture_list = []
+ folder_list = []
+- properties_dir = "/usr/share/cinnamon-background-properties"
++ properties_dir = "/usr/share/gnome-background-properties"
+ backgrounds = []
+ if os.path.exists(properties_dir):
+ for i in os.listdir(properties_dir):
+--
+2.16.4
+