summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-30 12:31:13 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-30 12:31:13 -0400
commitd2b464f7d9db6afdcc98baa51d4ff58a97893520 (patch)
treed2a0f7284c0ea939b29e91c2a7700af120d90e92 /gnome-extra/evolution-ews/evolution-ews-3.40.1.ebuild
parentmail-client/evolution: Version bump to 3.40.1 (diff)
downloadgentoo-d2b464f7d9db6afdcc98baa51d4ff58a97893520.tar.gz
gentoo-d2b464f7d9db6afdcc98baa51d4ff58a97893520.tar.bz2
gentoo-d2b464f7d9db6afdcc98baa51d4ff58a97893520.zip
gnome-extra/evolution-ews: Version bump to 3.40.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-ews/evolution-ews-3.40.1.ebuild')
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.40.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.40.1.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.40.1.ebuild
new file mode 100644
index 000000000000..2088827c2022
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.40.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.62:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}