summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-18 05:23:49 +0000
committerSam James <sam@gentoo.org>2021-04-18 05:24:08 +0000
commit8b7bcc8fd0b8d8c96313911bc04f7fac98517c6a (patch)
tree08db45cffb619fdd8eeccca0886e080b7fd1d95e /gnome-extra/evolution-ews
parentapp-admin/consul: Bump to version 1.9.5 (diff)
downloadgentoo-8b7bcc8fd0b8d8c96313911bc04f7fac98517c6a.tar.gz
gentoo-8b7bcc8fd0b8d8c96313911bc04f7fac98517c6a.tar.bz2
gentoo-8b7bcc8fd0b8d8c96313911bc04f7fac98517c6a.zip
gnome-extra/evolution-ews: fix build with CMake 3.20.1
Closes: https://bugs.gentoo.org/783603 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.38.4.ebuild3
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.40.0.ebuild3
-rw-r--r--gnome-extra/evolution-ews/files/evolution-ews-3.38.4-cmake-3.20.1.patch71
3 files changed, 77 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.38.4.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.38.4.ebuild
index 5a472956bac3..adff76ede31a 100644
--- a/gnome-extra/evolution-ews/evolution-ews-3.38.4.ebuild
+++ b/gnome-extra/evolution-ews/evolution-ews-3.38.4.ebuild
@@ -44,6 +44,9 @@ RESTRICT="test !test? ( test )"
# call; if needed, set them after cmake_src_prepare call, if that works
src_prepare() {
cmake_src_prepare
+
+ eapply "${FILESDIR}"/${PN}-3.38.4-cmake-3.20.1.patch
+
gnome2_src_prepare
}
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.40.0.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.40.0.ebuild
index 2088827c2022..394ab53f0341 100644
--- a/gnome-extra/evolution-ews/evolution-ews-3.40.0.ebuild
+++ b/gnome-extra/evolution-ews/evolution-ews-3.40.0.ebuild
@@ -44,6 +44,9 @@ RESTRICT="test !test? ( test )"
# call; if needed, set them after cmake_src_prepare call, if that works
src_prepare() {
cmake_src_prepare
+
+ eapply "${FILESDIR}"/${PN}-3.38.4-cmake-3.20.1.patch
+
gnome2_src_prepare
}
diff --git a/gnome-extra/evolution-ews/files/evolution-ews-3.38.4-cmake-3.20.1.patch b/gnome-extra/evolution-ews/files/evolution-ews-3.38.4-cmake-3.20.1.patch
new file mode 100644
index 000000000000..050bacd7628c
--- /dev/null
+++ b/gnome-extra/evolution-ews/files/evolution-ews-3.38.4-cmake-3.20.1.patch
@@ -0,0 +1,71 @@
+https://gitlab.gnome.org/GNOME/evolution-ews/-/commit/6d8f7d303ec319539add2f0ba5331c2dab9d23c7.patch
+https://bugs.gentoo.org/783603
+
+From 6d8f7d303ec319539add2f0ba5331c2dab9d23c7 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Wed, 14 Apr 2021 16:58:08 +0200
+Subject: [PATCH] PrintableOptions.cmake: Correct variable name comparison
+
+CMake 3.20.1 errors out with:
+
+CMake Error at cmake/modules/PrintableOptions.cmake:38 (message):
+ variable name cannot be empty
+ Call Stack (most recent call first):
+ CMakeLists.txt:152 (add_printable_variable)
+
+Change how the parameter value is compared, to fix it.
+--- a/cmake/modules/PrintableOptions.cmake
++++ b/cmake/modules/PrintableOptions.cmake
+@@ -19,40 +19,40 @@
+ # prints all the build options previously added with the above functions
+
+ macro(add_printable_variable_bare _name)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ list(APPEND _printable_options ${_name})
+ endmacro()
+
+ macro(add_printable_option _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "option name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ option(${_name} ${_description} ${_default_value})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE STRING ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable_path _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "path variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE PATH ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable_filepath _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "filepath variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE FILEPATH ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+--
+GitLab