summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-20 23:27:30 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-21 00:30:52 +0200
commitd6bd09be7883998d37b4420975d2cf3cd5fb171d (patch)
tree1752cc1fb910d7750eb4feb1799ead96383fd33e /gnome-extra/gnome-boxes
parentdev-util/devhelp: cleanup old revision (diff)
downloadgentoo-d6bd09be7883998d37b4420975d2cf3cd5fb171d.tar.gz
gentoo-d6bd09be7883998d37b4420975d2cf3cd5fb171d.tar.bz2
gentoo-d6bd09be7883998d37b4420975d2cf3cd5fb171d.zip
gnome-extra/gnome-boxes: version bump 3.20.2 → 3.22.1
usbredir and smartcard USE-flags are now enforced, apparently the fact that it was optional before was a hack for <qemu-1.3.1 according to NEWS. Package-Manager: portage-2.3.1
Diffstat (limited to 'gnome-extra/gnome-boxes')
-rw-r--r--gnome-extra/gnome-boxes/Manifest1
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.22.1.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index 5b1ca5a7a2d1..eac704a2e3e3 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1,2 +1,3 @@
DIST gnome-boxes-3.18.1.tar.xz 1655760 SHA256 0235d7f76cf3faa3889b302c743d608759e84506657ed4e374592c39f768fb2b SHA512 eb8cd1c4dde02435f8ac0c02181e37e5523a2d67b5a2196d0ba6a1af798392a59ac3706879331cc969f8e74ec476b1be478592413383683a316e95934e02087b WHIRLPOOL 68c1dac4545e71d8902d3b2efaa6cbd074ed7f97fa5cc2263fe2e28b9e166f439208f78fc179f375b574e70e81895b82fd59be310638bdab984c2ffb7e8da60b
DIST gnome-boxes-3.20.2.tar.xz 1686172 SHA256 c0379ce1de9d2a43a6875cbe1f2ef7ef69161b284926d59c44246a9142130fc5 SHA512 3ead46d8b65777e43bf55b04b9488a1a8c5d4a0bc46f582a46ae2d5ff883c01b5540739091c2f3065d3db666d38761dee6dacbde9d5c9042f5b79f1ad4769247 WHIRLPOOL 6545ae607965d51bea04335acb4050ccc606f764cb12e3a44a670007bd7d2387ca69f59539877ebce6ea8357dfcde6d6d786d2effac691f4ee1e8021a1ca64df
+DIST gnome-boxes-3.22.1.tar.xz 1737956 SHA256 be807d9336e96af6dea8f269a4b6dbbd3e9bb5fd135efc952aa2d62dde87b8ea SHA512 c5833e2af4977280c00b242a7b6703a5e7c58c59680aba793f3f6ec060676a6a542f29889fa5f48e4ba19792a7594e48d54a00d140b6be4ac3fa641dd6330d12 WHIRLPOOL 0b121af5375e9ea58f72c5e9db7eb6852f245ec2406a5751c1f5eee25b1e4aaade5478b8e40f6a418877d428b20a7f33b4e0ffcde4de52548c0988701e711662
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.22.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.22.1.ebuild
new file mode 100644
index 000000000000..2e2b8f9634b3
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.22.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 linux-info readme.gentoo-r1 vala
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+# We force 'bindist' due to licenses from gnome-boxes-nonfree
+IUSE="" #bindist
+
+KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only
+
+# NOTE: sys-fs/* stuff is called via exec()
+# FIXME: ovirt is not available in tree
+# FIXME: use vala.eclass but only because of libgd not being able
+# to use its pre-generated files so do not copy all the
+# vala deps like live ebuild has.
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-0.9.6:=
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-libs/libosinfo-0.2.12
+ >=app-emulation/qemu-1.3.1[spice]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.2.3
+ >=x11-libs/gtk+-3.19.4:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ >=net-misc/spice-gtk-0.27[gtk3]
+ virtual/libusb:1
+
+ >=app-misc/tracker-0.16:0=[iso]
+
+ >=sys-apps/util-linux-2.20
+ >=net-libs/libsoup-2.38:2.4
+
+ sys-fs/fuse
+ sys-fs/fuseiso
+ sys-fs/mtools
+ >=virtual/libgudev-165:=
+"
+# !bindist? ( gnome-extra/gnome-boxes-nonfree )
+
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+ fi
+}
+
+src_prepare() {
+ # Do not change CFLAGS, wondering about VALA ones but appears to be
+ # needed as noted in configure comments below
+ sed 's/CFLAGS="$CFLAGS -O0 -ggdb3"//' -i configure{.ac,} || die
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # debug needed for splitdebug proper behavior (cardoe), bug #????
+ gnome2_src_configure \
+ --enable-debug \
+ --disable-strict-cc \
+ --disable-ovirt
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}