summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-23 18:53:46 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-23 19:02:05 +0300
commitba36f5eb5f17063582858f31d9e4bd1b0db6e1ea (patch)
tree0b16a4dfef9cb1c337b3dab66eea281d5710434f /gnome-extra/gnome-calculator
parentdev-lang/vala: bump p.masked to 0.49.91 (diff)
downloadgentoo-ba36f5eb5f17063582858f31d9e4bd1b0db6e1ea.tar.gz
gentoo-ba36f5eb5f17063582858f31d9e4bd1b0db6e1ea.tar.bz2
gentoo-ba36f5eb5f17063582858f31d9e4bd1b0db6e1ea.zip
gnome-extra/gnome-calculator: bump to 3.36.0
Closes: https://bugs.gentoo.org/723256 Closes: https://bugs.gentoo.org/718840 Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-calculator')
-rw-r--r--gnome-extra/gnome-calculator/Manifest1
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.36.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calculator/Manifest b/gnome-extra/gnome-calculator/Manifest
index 1fa0259530ab..71e7f10071fe 100644
--- a/gnome-extra/gnome-calculator/Manifest
+++ b/gnome-extra/gnome-calculator/Manifest
@@ -1 +1,2 @@
DIST gnome-calculator-3.34.1.tar.xz 965520 BLAKE2B 7dd7af4d2065aee9a8962983ebf723aa06e4b2e3ef98213a89044d70e47057a747a88fdd58185abb272589433f84a6fcd3a3c5fd7dc0281d13f34ccaba690b50 SHA512 43900cebc6b479292a45619f1e4f6afc5264e2dceda5d0049b59f27ebe2a32b5f4b2465a22f33b33b882ab0e737f7048fbe9395b18f9b5d2023da2941b6783f6
+DIST gnome-calculator-3.36.0.tar.xz 983532 BLAKE2B 5e28a82cb93cb944e69d4d7c7cf1a14cd91375ef864cbd5624d87a66ee79f0aff17f871ba734d35ae372b761ce67c809acb6fdfe66597980f33e06fe86d6157d SHA512 5e8d3b17703260928e9d0594a6e0b06b6a25d71590b4ab6c371e0c21be5e53698011407886f09f6bd67660ecbfa182d725d5e3a1c51fe4ea9125b175bd4d279c
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.36.0.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.36.0.ebuild
new file mode 100644
index 000000000000..a8604b323e2a
--- /dev/null
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.36.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala virtualx xdg
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# gtksourceview vapi definitions in dev-lang/vala itself are too old, and newer vala removes them
+# altogether, thus we need them installed by gtksourceview[vala]
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ >=dev-libs/libgee-0.20.0:0.8
+ dev-libs/mpc:=
+ dev-libs/mpfr:0=
+ >=x11-libs/gtk+-3.19.3:3
+ >=x11-libs/gtksourceview-4.0.2:4
+ introspection? ( >=dev-libs/gobject-introspection-1.58:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ net-libs/libsoup:2.4[vala]
+ x11-libs/gtksourceview:4[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+ # Automagic dep on valadoc - don't bother for now
+ sed -e '/subdir.*doc/d' -i meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddisable-ui=false
+ #-Dvala-version # doesn't do anything in 3.34
+ $(meson_use !introspection disable-introspection)
+ $(meson_use test ui-tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}