summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-07-15 10:16:25 +0200
committerPacho Ramos <pacho@gentoo.org>2020-07-15 10:22:30 +0200
commit65a3e0d729da51012441ee0e06bd642952eb0b5d (patch)
tree4b5d1d2ec78e31215d16f5339dd7f389e585c03b /gnome-extra/gnome-shell-extension-applications-overview-tooltip
parentprofiles: package.mask dev-perl/Data-Diver (diff)
downloadgentoo-65a3e0d729da51012441ee0e06bd642952eb0b5d.tar.gz
gentoo-65a3e0d729da51012441ee0e06bd642952eb0b5d.tar.bz2
gentoo-65a3e0d729da51012441ee0e06bd642952eb0b5d.zip
gnome-extra/gnome-shell-extension-applications-overview-tooltip: Bump to v8
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-8.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
index 20b5adfd2c73..38f1d09126c9 100644
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-applications-overview-tooltip-7.tar.gz 79965 BLAKE2B f7698bdad46837f1ae736bbb2d9b376a28946df5f8a00d2e9b19d48bc4c2f4e742030f952d14bf5816ca1aae9b172a2639e2170d6bd87f373ff23c7ce9bd8912 SHA512 1cfaf23fefe5a940ae448658e176c69da9bb319f6200983b4ac14f65e76f5e449b9a235e6c1ccaf9b6d6db0fda9576e963fa1273b776dbfb5a72c608961e2d48
+DIST gnome-shell-extension-applications-overview-tooltip-8.tar.gz 79996 BLAKE2B a6686a1c3a853066bb578029eddab47391bb64fed0f61b9c2244d21362fb11155905288032fb7444a1557f4ac180e44b176b4ac788789f9519daf8aec2cab666 SHA512 cf0254cc182ecb7d96cc33c45a36713f246fa80426fb8604ee60503ecb8668fae0162a07db63f7fdfa9817f55c1835871dadb0be9d9d1aeb22afdbe9aea15e99
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-8.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-8.ebuild
new file mode 100644
index 000000000000..c88a77d8ce4f
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.36
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P/gnome-shell-extension-}"
+
+src_install() {
+ einstalldocs
+ rm -f README.md || die
+ insinto /usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet
+ doins -r *
+ glib-compile-schemas "${ED}"/usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet/schemas || die
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}