summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-12-21 19:40:24 +0100
committerPacho Ramos <pacho@gentoo.org>2021-12-21 19:54:47 +0100
commitf7acbec7c896f6da1567b64774e65e1af5c3ef38 (patch)
tree313fe828668f408debcc35fbdd339e762b29db57 /gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen
parentdev-python/pyclipper: Version bump (diff)
downloadgentoo-f7acbec7c896f6da1567b64774e65e1af5c3ef38.tar.gz
gentoo-f7acbec7c896f6da1567b64774e65e1af5c3ef38.tar.bz2
gentoo-f7acbec7c896f6da1567b64774e65e1af5c3ef38.zip
gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen: Bump to new snapshot
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen')
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20211209.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
index cb852c3c8d0f..f76c19873e68 100644
--- a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
@@ -1,3 +1,4 @@
DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20210614.tar.gz 14863 BLAKE2B 11133a5bf6ea06acd2fce6f215fcc6a37a658857161b9babab51246d6d7d382773e92f395796410fafa903ace656aa664c749a501bcbd4d05ebbd81ea9fd5018 SHA512 06f6329a6a2b2e03cacd305e1dad81768b81d6193782739caeadc51f141da9238d2bff563276235673e492ad7f13977fe7f1eaba73ca940a410b94defbeae5b0
DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20210721.tar.gz 2592 BLAKE2B 205309c4057094301e3469471b0f2da06a6cdf6f36b430b636f5341acde98ae999a537ca3a815a257fd9e3abde8f30bffb9a78f38926224eea3ec29d92548f2b SHA512 d314227588dac2f51b1d6946bac29501607b3e4fa6c3394b4bf56576453d6e6aa5a76fb2b576e216d5e62dabd8994418f11838d95bd90f134d261223fab04dd8
DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20211111.tar.gz 2595 BLAKE2B c15c74cd534e571585b1129216fe644d7c8c2b78cf360d26ac48cf1773e3b69e97c3889e13f39355c24b2066168f9cdd2a6e49f830c20f1f6f853aecba6b0ebe SHA512 b3dfa72863972af9ada7803aeff409139708840b795842c32ce6b07cea21e472c06c4ec86eb141b0fd89a31912971d3b97fd96ee4e3d8bc63928f551bf7c9836
+DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20211209.tar.gz 2609 BLAKE2B 17b75fab4c2c01635ef578444ab2d17ef19abad4fe9ef92ac46ea00e6ee7fa5138364e950e75b7ed581249c650e745fb7cb6adfa18a85a42cbba2d9a7d62555e SHA512 ceaf49c034d90d30534b36a0bd47b18e492a052724820887e284f4e5fe7b7faac24baa19581d113f176ce13082ec080de5562555dc2b65481b187543a60da9cc
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20211209.ebuild b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20211209.ebuild
new file mode 100644
index 000000000000..12902d135edb
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20211209.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Control the blur effect on gnome-shell lock screen"
+HOMEPAGE="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen"
+COMMIT="0223e85a5045e9589cb8186376d9258e845789bd"
+SRC_URI="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+extension_uuid="ControlBlurEffectOnLockScreen@pratap.fastmail.fm"
+S="${WORKDIR}/${PN/gnome-shell-extension-/}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf LICENSE README.md schemas
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}