summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-20 12:08:51 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-20 12:20:57 -0700
commit446069ba57c3128b130947a83ce0dd1889d819c3 (patch)
treedb3c49ca17c1adf6351ad54be51dd893fa745fc6 /gnome-extra/office-runner
parentsys-apps/portage: 3.0.20-r5 revbump for EAPI 8 fix (diff)
downloadgentoo-446069ba57c3128b130947a83ce0dd1889d819c3.tar.gz
gentoo-446069ba57c3128b130947a83ce0dd1889d819c3.tar.bz2
gentoo-446069ba57c3128b130947a83ce0dd1889d819c3.zip
gnome-extra/office-runner: Version bump to 1.0.3
Closes: https://bugs.gentoo.org/778698 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/office-runner')
-rw-r--r--gnome-extra/office-runner/Manifest1
-rw-r--r--gnome-extra/office-runner/office-runner-1.0.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gnome-extra/office-runner/Manifest b/gnome-extra/office-runner/Manifest
index 5c76ba80c964..e7a7468d567c 100644
--- a/gnome-extra/office-runner/Manifest
+++ b/gnome-extra/office-runner/Manifest
@@ -1 +1,2 @@
DIST office-runner-1.0.2.tar.xz 562660 BLAKE2B ad69a4340025b58d45f954524c9807831c98a4d81901276bfa3e8f76adb3a5bd1fcf0b50908e00c19888d82b6c48602228a42b84b008f2b7b95210868c8a90ed SHA512 a840af75f014147d30e950a4bc8628c97a79c8161eab3d0f658f5e4f5200df5baaa761d4ea27dc1bc70c6a467fc2536ac0aa473c338ffcbfc48689ba1ec13177
+DIST office-runner-1.0.3.tar.bz2 957912 BLAKE2B 064dac6f511d9c1019a2da073276509d6ccf9bce19ae1778335f5dde3fe1f236a76430dd3fb989f06e64d0214b5125769b0a3531cba44460ae15b0ad8b87f07d SHA512 475aac701cd4faec378e4f7673658489e9d4cebea499b24fb2baa6cc981ed1dab435769ce75ed82ffa9d28bf29e96d2911820a29abaa5aafed7d38af80636584
diff --git a/gnome-extra/office-runner/office-runner-1.0.3.ebuild b/gnome-extra/office-runner/office-runner-1.0.3.ebuild
new file mode 100644
index 000000000000..62c820e0058e
--- /dev/null
+++ b/gnome-extra/office-runner/office-runner-1.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GNOME2_EAUTORECONF="yes"
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Lighthearted tool to temporarily inhibit GNOME's suspend on lid close behavior"
+HOMEPAGE="https://www.hadess.net/search/label/office-runner"
+SRC_URI="https://gitlab.gnome.org/GNOME/office-runner/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ >=gnome-base/gnome-settings-daemon-3.0
+ >=x11-libs/gtk+-3.8:3
+"
+# requires systemd's org.freedesktop.login1 dbus service
+RDEPEND="${DEPEND}
+ >=sys-apps/systemd-190
+"
+BDEPEND="
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+DOC_CONTENTS="${PN} inhibits suspend on lid close only for 10 minutes"
+
+src_install() {
+ gnome2_src_install
+ mv "${ED}"/usr/share/{appdata,metainfo}/ || die
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}