summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-22 11:12:31 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-23 00:03:35 -0400
commitb6f5e243e40d4d4a1c3796acafb4ad50b2fbb968 (patch)
treea82deb453b872f1cab9ba12ac6a43ba512000e42 /gnome-extra/yelp
parentgames-emulation/pcsx2: sync live (diff)
downloadgentoo-b6f5e243e40d4d4a1c3796acafb4ad50b2fbb968.tar.gz
gentoo-b6f5e243e40d4d4a1c3796acafb4ad50b2fbb968.tar.bz2
gentoo-b6f5e243e40d4d4a1c3796acafb4ad50b2fbb968.zip
gnome-extra/yelp: Version bump to 42.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/yelp')
-rw-r--r--gnome-extra/yelp/Manifest1
-rw-r--r--gnome-extra/yelp/yelp-42.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/yelp/Manifest b/gnome-extra/yelp/Manifest
index 35fbec65c029..11d14c22b404 100644
--- a/gnome-extra/yelp/Manifest
+++ b/gnome-extra/yelp/Manifest
@@ -1 +1,2 @@
DIST yelp-42.1.tar.xz 1512620 BLAKE2B a0ba02a560c19e516c42f77a34f3296dd6dd9d3dba9b34b2243a2c7689b7117cd82dea8e169ec7001ba15860c74f1c7ace061094516391b38f5054b566e613b2 SHA512 3c8150503e828c8d2994b7af6f7c673b696b01f4a82abcbbc0395909a0e0eb2d64a9e445a5b1683a0c9aa0abc7040cc563917e55b126879ce7c4dda117bbf3db
+DIST yelp-42.2.tar.xz 1506136 BLAKE2B dbde815af6902eebae0e6dcdb12e0e0c8981fa64608e6ba3c8950b908b13981c335011ee2e2240e8a96c4aff3f8b682d630ea34215918374e231220eb87e0f2b SHA512 7fd8da347b3cdb9b24a31eebe14c4964c5e41956caa2b79e70d6ea0c829d94f8428bbd96a2472c02d56673ca0ed1c75f7c6f874a59c4eea0b1440918a99969f4
diff --git a/gnome-extra/yelp/yelp-42.2.ebuild b/gnome-extra/yelp/yelp-42.2.ebuild
new file mode 100644
index 000000000000..db120a9de577
--- /dev/null
+++ b/gnome-extra/yelp/yelp-42.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ app-arch/bzip2:=
+ >=app-arch/xz-utils-4.9:=
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.67.4:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=gnome-extra/yelp-xsl-41.0
+ >=net-libs/webkit-gtk-2.19.2:4
+ >=x11-libs/gtk+-3.13.3:3
+ >=gui-libs/libhandy-1.5.0:1
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ >=dev-util/gtk-doc-am-1.13
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch # needs eautoreconf
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-webkit2gtk-4-0 \
+ --enable-bz2 \
+ --enable-lzma \
+ APPSTREAM_UTIL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ exeinto /usr/libexec/
+ doexe "${S}"/libyelp/yelp-groff
+}