summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-01-01 22:21:34 +0100
committerPacho Ramos <pacho@gentoo.org>2016-01-01 22:21:34 +0100
commit6d4013959da6485ead5cfdb8913234b9545d9a50 (patch)
tree4b753d3254392e43e59095a2f4e1823fdc061382 /gnome-extra
parentapp-emulation/open-vm-tools: Fix building with latest glibmm/libsigc++ (#570418) (diff)
downloadgentoo-6d4013959da6485ead5cfdb8913234b9545d9a50.tar.gz
gentoo-6d4013959da6485ead5cfdb8913234b9545d9a50.tar.bz2
gentoo-6d4013959da6485ead5cfdb8913234b9545d9a50.zip
gnome-extra/eiciel: Fix building with latest glibmm/libsigc++
Package-Manager: portage-2.2.26
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/eiciel/eiciel-0.9.11-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnome-extra/eiciel/eiciel-0.9.11-r1.ebuild b/gnome-extra/eiciel/eiciel-0.9.11-r1.ebuild
new file mode 100644
index 000000000000..56058320c516
--- /dev/null
+++ b/gnome-extra/eiciel/eiciel-0.9.11-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
+HOMEPAGE="http://rofi.roger-ferrer.org/eiciel/"
+SRC_URI="http://rofi.roger-ferrer.org/eiciel/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xattr"
+
+RDEPEND="
+ >=sys-apps/acl-2.2.32
+ >=dev-cpp/gtkmm-3:3.0
+ >=gnome-base/nautilus-3
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.18.1
+"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-version=3 \
+ $(use_enable xattr user-attributes)
+}