summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-02 10:50:36 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-02 11:01:33 -0400
commitc7556bd82768cd98cb68768f427fa3dfd99d1343 (patch)
tree2a0bd03dbf0f3602edc435b1ae046e0ae1383cce /gnome-extra
parentsci-geosciences/gnome-maps: Version bump to 40.1 (diff)
downloadgentoo-c7556bd82768cd98cb68768f427fa3dfd99d1343.tar.gz
gentoo-c7556bd82768cd98cb68768f427fa3dfd99d1343.tar.bz2
gentoo-c7556bd82768cd98cb68768f427fa3dfd99d1343.zip
gnome-extra/gnome-user-docs: Version bump to 40.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-40.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index 0bf66c514df4..cdc94da3783f 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1,2 +1,3 @@
DIST gnome-user-docs-3.36.6.tar.xz 10607064 BLAKE2B 2b6173905f16a72885ea684e79930ee9425adea7b98b11f324df48c5f788a6f72aafcf9b782aae764eca3db451bd232be6f2572eec6278e179ae04102c863a1f SHA512 62384715c9cfa82fcf39f93d574e61aa2a127060f558f7f68b7ce1a3a724cf1670affeff165cff16b6c019b2c4135a517d39da6be859e8756c850763c912f3ab
DIST gnome-user-docs-40.0.tar.xz 8974868 BLAKE2B 4598074620fa08c4e9f9bb8d7267252abe4f0a026668d1236cd516f832b457e675326789ed0c8ac6efb71b81a75a1e40aa8dee6049a188d79c289a8af3991661 SHA512 0e878c28a1d8fa74dd44b5be0562f0a45056ab1eabd1f00e81db46d69fc39e9a5a833cbbd42704fd998a5f724c323902323ab5b100be6c58089d9051302a14b5
+DIST gnome-user-docs-40.1.tar.xz 9264892 BLAKE2B 3c27662d516839d411444b811d2c60da51b055a7200958ee50908092bd135e182c2b359f47b711b276a6a9b6b029b767b23bd88fecc32f2c80fa2652ace40184 SHA512 a5ebd9bfbdf13c6922db2035c740f729dc89a2dfa991e74cb835d1c8e28ec4d0d08aaf7388d00d6df83f53a6261bebc1ea32e5b57287c13b2237221a56a34332
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-40.1.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-40.1.ebuild
new file mode 100644
index 000000000000..9b013790bb62
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-40.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}