summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/cynthiune
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/cynthiune')
-rw-r--r--gnustep-apps/cynthiune/Manifest1
-rw-r--r--gnustep-apps/cynthiune/cynthiune-1.0.0.ebuild60
-rw-r--r--gnustep-apps/cynthiune/metadata.xml42
3 files changed, 103 insertions, 0 deletions
diff --git a/gnustep-apps/cynthiune/Manifest b/gnustep-apps/cynthiune/Manifest
new file mode 100644
index 000000000000..18e2fdabdffc
--- /dev/null
+++ b/gnustep-apps/cynthiune/Manifest
@@ -0,0 +1 @@
+DIST Cynthiune-1.0.0.tar.gz 570554 SHA256 3cc5228c8cdb66256bbcec4b317bbd3853397f09ec9b7378a7f65140eff5bcaf SHA512 ae56a77a138b2f661ecedbbad89935c3e8ec44447b000b73985577ea28304d11bb957fe118ba844168e9c7a06a229e8b024a6bc6eb4199080d6e69b77a31b4b7 WHIRLPOOL 4e9956e723c4c588da2c5a28d2cf01d3458815d2e59c479de65328f4836e376f3b98a86d212e0c39021c13182a0b9b39e7758e3043db1b9df064df8f2783c96e
diff --git a/gnustep-apps/cynthiune/cynthiune-1.0.0.ebuild b/gnustep-apps/cynthiune/cynthiune-1.0.0.ebuild
new file mode 100644
index 000000000000..e22770adf148
--- /dev/null
+++ b/gnustep-apps/cynthiune/cynthiune-1.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnustep-2
+
+MY_P=${P/c/C}
+DESCRIPTION="Free software and romantic music player for GNUstep"
+HOMEPAGE="http://gap.nongnu.org/cynthiune/"
+SRC_URI="http://savannah.nongnu.org/download/gap/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="alsa ao flac mad modplug musepack oss timidity vorbis"
+
+# musicbrainz disabled upstream for now
+RDEPEND="media-libs/audiofile
+ media-libs/taglib
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libid3tag
+ media-libs/libmad )
+ musepack? ( >=media-sound/musepack-tools-444 )
+ modplug? ( media-libs/libmodplug )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libogg-1.1.2
+ >=media-libs/libvorbis-1.0.1-r2 )"
+DEPEND="${RDEPEND}
+ mad? ( virtual/pkgconfig )"
+
+S=${WORKDIR}/${MY_P}
+
+cynthiune_get_config() {
+ local myconf="disable-windowsmedia=yes disable-esound=yes"
+ use alsa || myconf="${myconf} disable-alsa=yes"
+ use ao || myconf="${myconf} disable-ao=yes"
+ use flac || myconf="${myconf} disable-flac=yes disable-flactags=yes"
+ use mad || myconf="${myconf} disable-mp3=yes disable-id3tag=yes"
+ use modplug || myconf="${myconf} disable-mod=yes"
+ use musepack || myconf="${myconf} disable-musepack=yes"
+ use oss || myconf="${myconf} disable-oss=yes"
+ use timidity || myconf="${myconf} disable-timidity=yes"
+ use vorbis || myconf="${myconf} disable-ogg=yes disable-vorbistags=yes"
+
+ echo ${myconf}
+}
+
+src_compile() {
+ egnustep_env
+ egnustep_make "$(cynthiune_get_config)"
+}
+
+src_install() {
+ egnustep_env
+ egnustep_install "$(cynthiune_get_config)"
+}
diff --git a/gnustep-apps/cynthiune/metadata.xml b/gnustep-apps/cynthiune/metadata.xml
new file mode 100644
index 000000000000..7c7458d44268
--- /dev/null
+++ b/gnustep-apps/cynthiune/metadata.xml
@@ -0,0 +1,42 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+Cynthiune (january 2004)
+=========
+
+What is Cynthiune?
+------------------
+Cynthiune is a free software and romantic music player for GNUstep and MacOSX.
+I wrote it originally as a christmas gift to a girl that I liked because she
+could not listen to music on her Mac with a free program. Since then, I decided
+to make it public and add even more features to make it a complete and useable
+media player.
+
+For the moment, it looks pretty much like XMMS, Winamp and similar software.
+Even though it has far less features than those, the essential components of a
+usable and user-friendly program are there in my opinion.
+
+From a programmatic point-of-view, I have decided to write a program that is
+released only when considered bug-free. The free software community lacks,
+IMnsHO, a sense of quality that makes its programs nearly useless to
+lambda users. Not only is it useless, but I think it also gives free software
+a bad reputation. The principle of freedom in "free software" is fundamental
+to me, but it has to be reachable not only by some sort of geeky elite. There
+is no point in telling users that since they have the freedom to enhance those
+programs, they must fix them if they want to use them. Releasing a program
+with too many bugs is of no use and is likely not to interest other fellow
+programmers in the community either.
+
+On the other hand, Apple has published an interesting program called "iTunes".
+Of course, it is not free software but it does implement interesting ideas
+that I would like to include in Cynthiune. For example: CD burning, complete
+playlist management, etc... Personally I find its user interface to be not as
+user-friendly as it could be. My plan is thus to take advantage of my own
+programming skills and sense of aesthetics (and ergonomy) to try to write
+something a little bit different, inspired both by XMMS/Winamp and iTunes.
+Cynthiune is thus currently very basic but its core design is starting to be
+extensible enough that it will not be too much trouble to enhance it.
+</longdescription>
+</pkgmetadata>