summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/gemas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/gemas')
-rw-r--r--gnustep-apps/gemas/Manifest2
-rw-r--r--gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch24
-rw-r--r--gnustep-apps/gemas/gemas-0.3.ebuild22
-rw-r--r--gnustep-apps/gemas/gemas-0.4.ebuild45
-rw-r--r--gnustep-apps/gemas/metadata.xml9
5 files changed, 102 insertions, 0 deletions
diff --git a/gnustep-apps/gemas/Manifest b/gnustep-apps/gemas/Manifest
new file mode 100644
index 000000000000..917a82af1723
--- /dev/null
+++ b/gnustep-apps/gemas/Manifest
@@ -0,0 +1,2 @@
+DIST Gemas-0.3.tar.gz 89459 SHA256 3633404e429cb713b78c9c2220548c3adaa3eb8d79b97da5597a2b2f29f0123d
+DIST Gemas-0.4.tar.gz 552558 SHA256 db1709aac8ed4d5c609c19a922eb2d6ea518e5379a068dd03b2635970b4c59cd SHA512 6ae1acadd1be71362d93ac44498b789d160146f02c995280a003ac748c4d5dde615854014351c560e4e49576c20094dce0c4e2bef0c8096368c0c25679670e58 WHIRLPOOL 51c1b54f597773f427fc87511b6307ba8f926cc87d1685943bfef4529594d7e9cb8d71883debbde2bfa0f6132049f14f3007712e1b38fba438cf75dba8d2757c
diff --git a/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch b/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch
new file mode 100644
index 000000000000..73595f256b56
--- /dev/null
+++ b/gnustep-apps/gemas/files/gemas-0.4-bundle_makefile.patch
@@ -0,0 +1,24 @@
+diff -Naur Gemas-0.4.orig/Bundle/Gemas/GNUmakefile Gemas-0.4/Bundle/Gemas/GNUmakefile
+--- Gemas-0.4.orig/Bundle/Gemas/GNUmakefile 2013-12-24 18:51:16.000000000 +0100
++++ Gemas-0.4/Bundle/Gemas/GNUmakefile 2014-02-10 10:50:45.331011111 +0100
+@@ -10,7 +10,7 @@
+ BUNDLE_NAME = Gemas
+ BUNDLE_EXTENSION = .editor
+ Gemas_PRINCIPAL_CLASS = GemasEditor
+-Gemas_INSTALL_DIR=$(GNUSTEP_LOCAL_APPS)/ProjectCenter.app/Resources
++Gemas_INSTALL_DIR=${DESTDIR}/$(GNUSTEP_SYSTEM_APPS)/ProjectCenter.app/Resources
+
+ #
+ # Additional libraries
+diff -Naur Gemas-0.4.orig/Bundle/Gemas/GNUmakefile.preamble Gemas-0.4/Bundle/Gemas/GNUmakefile.preamble
+--- Gemas-0.4.orig/Bundle/Gemas/GNUmakefile.preamble 2013-12-24 18:51:16.000000000 +0100
++++ Gemas-0.4/Bundle/Gemas/GNUmakefile.preamble 2014-02-10 10:50:50.622016109 +0100
+@@ -15,7 +15,7 @@
+ ADDITIONAL_LDFLAGS +=
+
+ # Additional include directories the compiler should search
+-ADDITIONAL_INCLUDE_DIRS +=-I$(GNUSTEP_LOCAL_HEADERS)/ProjectCenter
++ADDITIONAL_INCLUDE_DIRS +=-I$(GNUSTEP_SYSTEM_HEADERS)/ProjectCenter
+
+ # Additional library directories the linker should search
+ ADDITIONAL_LIB_DIRS += -L./HighlighterKit/HighlighterKit.framework
diff --git a/gnustep-apps/gemas/gemas-0.3.ebuild b/gnustep-apps/gemas/gemas-0.3.ebuild
new file mode 100644
index 000000000000..797a34b8476f
--- /dev/null
+++ b/gnustep-apps/gemas/gemas-0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnustep-2
+
+MY_P=${P/g/G}
+DESCRIPTION="a simple code editor for GNUstep"
+HOMEPAGE="http://wiki.gnustep.org/index.php/Gemas.app"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=gnustep-libs/highlighterkit-0.1.2
+ >=virtual/gnustep-back-0.22.0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
diff --git a/gnustep-apps/gemas/gemas-0.4.ebuild b/gnustep-apps/gemas/gemas-0.4.ebuild
new file mode 100644
index 000000000000..0de1fb17ff42
--- /dev/null
+++ b/gnustep-apps/gemas/gemas-0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnustep-2
+
+MY_P=${P/g/G}
+DESCRIPTION="a simple code editor for GNUstep"
+HOMEPAGE="http://wiki.gnustep.org/index.php/Gemas.app"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="projectcenter"
+
+DEPEND=">=gnustep-libs/highlighterkit-0.1.2
+ >=virtual/gnustep-back-0.22.0
+ projectcenter? ( gnustep-apps/projectcenter )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-bundle_makefile.patch
+}
+
+src_compile() {
+ gnustep-base_src_compile
+ if use projectcenter;
+ then
+ cd Bundle/Gemas || die "compile cd failed"
+ egnustep_make
+ fi
+}
+
+src_install() {
+ gnustep-base_src_install
+ if use projectcenter;
+ then
+ cd Bundle/Gemas || die "install cd failed"
+ egnustep_install
+ fi
+}
diff --git a/gnustep-apps/gemas/metadata.xml b/gnustep-apps/gemas/metadata.xml
new file mode 100644
index 000000000000..5fcc88f636fc
--- /dev/null
+++ b/gnustep-apps/gemas/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>Gemas is a simple code editor for GNUstep. It have autoindentation and highlight syntax for C, C++, Objective-C, Objective-C++, GSmarkup. And to edit Strings, Plist, GNUmakefile, ChangeLog files and plain text files (INSTALL, README, ...)</longdescription>
+ <use>
+ <flag name='projectcenter'>Build and install plugin for <pkg>gnustep-apps/projectcenter</pkg></flag>
+ </use>
+</pkgmetadata>