summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-07-25 14:04:22 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-07-25 14:04:55 +0200
commit72c0564a48949811320fc67457da72baac64d254 (patch)
treeb2efbe8b7b11d37fbca3e3d738106984010f67a5 /gnustep-apps/sogo
parentgnustep-libs/sope: 3.2.10 bump (diff)
downloadgentoo-72c0564a48949811320fc67457da72baac64d254.tar.gz
gentoo-72c0564a48949811320fc67457da72baac64d254.tar.bz2
gentoo-72c0564a48949811320fc67457da72baac64d254.zip
gnustep-apps/sogo: 3.2.10 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'gnustep-apps/sogo')
-rw-r--r--gnustep-apps/sogo/Manifest1
-rw-r--r--gnustep-apps/sogo/sogo-3.2.10.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/Manifest b/gnustep-apps/sogo/Manifest
index 8a67c93898a2..5b30a48cc57f 100644
--- a/gnustep-apps/sogo/Manifest
+++ b/gnustep-apps/sogo/Manifest
@@ -1 +1,2 @@
+DIST sogo-3.2.10.tar.gz 32528115 SHA256 3bad2d871c750346624bae3b66e25080727391be40f71477f7c3102c7bc559ce SHA512 3dbd465592fd98968b32e251659a70306a781999bcfa9e63e142d75d7c9274edc7cbe5069881e939f0e9472f0ef8580e4e0f20059bfc97f8c69893d86c8cadf3 WHIRLPOOL 99e47eb3f95e04b07e354d0522e186c5c27ed0e74012e1cacf06cfbdbe083002184123b602e7ad1c062ef2ab3fff865e54d921b1a1474331756552db53335aad
DIST sogo-3.2.9.tar.gz 32443733 SHA256 c28591e738c5c57428c63504a52ef527898e7a4c6af444ccfe988ccfb5c4f8b1 SHA512 070b3812d65598364d9204432678ea48705bf7481371e44442a13ad86d219415e24c579ad59212a7631922a527d30e69aeb17711c3abfc01960f663f4e0112a3 WHIRLPOOL bb8dd3053c96acb507a3d620a191ebe6225d157995af4428b66755bf38061226cd4d9537413117477d40c095531ca46040d28c78b97f2aeea520bb4ae318683c
diff --git a/gnustep-apps/sogo/sogo-3.2.10.ebuild b/gnustep-apps/sogo/sogo-3.2.10.ebuild
new file mode 100644
index 000000000000..5c728f4bdae5
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-3.2.10.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnustep-2 user vcs-snapshot
+
+DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://www.sogo.nu"
+SRC_URI="https://github.com/inverse-inc/sogo/archive/SOGo-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls libressl +ssl"
+
+RDEPEND="
+ dev-libs/libmemcached
+ net-misc/curl
+ net-misc/memcached
+ >=gnustep-libs/sope-${PV}[ldap]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.3"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+pkg_setup() {
+ enewuser sogo -1 /bin/bash /var/lib/sogo
+}
+
+src_prepare() {
+ gnustep-base_src_prepare
+ sed -e "s/validateArgs$//" -i configure \
+ || die "GNUstep.conf sed failed"
+
+ default
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ ./configure \
+ --disable-strip \
+ --prefix=/usr \
+ --with-ssl="${ssl_provider}" \
+ $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ newconfd "${FILESDIR}"/sogod.confd sogod
+ newinitd "${FILESDIR}"/sogod.initd sogod
+
+ insinto /etc/logrotate.d
+ newins Scripts/logrotate sogo
+ newdoc Apache/SOGo.conf SOGo-Apache.conf
+
+ insinto /etc/sogo
+ doins Scripts/sogo.conf
+
+ insinto /etc/cron.d
+ newins Scripts/sogo.cron sogo
+ keepdir /var/log/sogo
+
+ fowners sogo:sogo /var/log/sogo
+ fowners -R root:sogo /etc/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+ elog "SOGo documentation is available online at:"
+ elog "http://www.sogo.nu/downloads/documentation.html"
+ elog
+ elog "Apache sample configuration file is available in:"
+ elog "/usr/share/doc/${PF}"
+}