summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-libs/dbuskit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-libs/dbuskit')
-rw-r--r--gnustep-libs/dbuskit/Manifest2
-rw-r--r--gnustep-libs/dbuskit/dbuskit-0.1.1.ebuild31
-rw-r--r--gnustep-libs/dbuskit/dbuskit-0.1.ebuild32
-rw-r--r--gnustep-libs/dbuskit/files/dbuskit-0.1-configure.patch31
-rw-r--r--gnustep-libs/dbuskit/metadata.xml6
5 files changed, 102 insertions, 0 deletions
diff --git a/gnustep-libs/dbuskit/Manifest b/gnustep-libs/dbuskit/Manifest
new file mode 100644
index 000000000000..e324cc2985f5
--- /dev/null
+++ b/gnustep-libs/dbuskit/Manifest
@@ -0,0 +1,2 @@
+DIST dbuskit-0.1.1.tar.gz 706783 SHA256 3995867173148663cec6d98010b1c23e5fec827ff6b801f1ae6a4e9949b0f7b5 SHA512 1d98a05bda7558ebca80c5a4985009bdcb2f875c25f44872a2ae589793deb2d6d832c91e3eeaed7846980f5921a6a543efd04db3f7b228a0d0bae37cdc5ccfae WHIRLPOOL 5172636a3d64d721cd21022ebf67866d81b9309c81152683bf1285ee66b67f58068b543bab13f7cfbcb08952ffab6c7e7ecd9129ee1ebac950e3c11077751502
+DIST dbuskit-0.1.tar.bz2 430580 SHA256 8a6c7ea00a393f43e8cf0dd2337bc6b58e8f542b42568324f996a2070de3380c SHA512 194e728a31401865b0c2558d7e5992a00abf520a373f203fea7ecc74fdbc4248f6016624c00b1bbd2718b6842d7f08fcea78654289f1e4857914234652378a99 WHIRLPOOL b5faeed275bc007a6fc784c3097884ed1dc2ae7757d889207eb41053bc7617912d7eba56e0f9390c889044088777958c7c34b25c1bf48a4fc61749673fed061b
diff --git a/gnustep-libs/dbuskit/dbuskit-0.1.1.ebuild b/gnustep-libs/dbuskit/dbuskit-0.1.1.ebuild
new file mode 100644
index 000000000000..17a03f3f80dd
--- /dev/null
+++ b/gnustep-libs/dbuskit/dbuskit-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools gnustep-2
+
+DESCRIPTION="framework that interfaces Objective-C applications with the D-Bus IPC service"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/dbus-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ # Bug 410697
+ sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
+ -i configure.ac || die "ObjectiveC2 runtime sed failed"
+ eautoreconf
+}
diff --git a/gnustep-libs/dbuskit/dbuskit-0.1.ebuild b/gnustep-libs/dbuskit/dbuskit-0.1.ebuild
new file mode 100644
index 000000000000..a0698e2e1b0f
--- /dev/null
+++ b/gnustep-libs/dbuskit/dbuskit-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools gnustep-2
+
+DESCRIPTION="framework that interfaces Objective-C applications with the D-Bus IPC service"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/dbus-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.patch
+ # Bug 410697
+ sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
+ -i configure.ac || die "ObjectiveC2 runtime sed failed"
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ eautoreconf
+}
diff --git a/gnustep-libs/dbuskit/files/dbuskit-0.1-configure.patch b/gnustep-libs/dbuskit/files/dbuskit-0.1-configure.patch
new file mode 100644
index 000000000000..9a25bcef6adb
--- /dev/null
+++ b/gnustep-libs/dbuskit/files/dbuskit-0.1-configure.patch
@@ -0,0 +1,31 @@
+http://svn.gna.org/viewcvs/gnustep?view=revision&revision=34602
+Backport configure script improvements.
+--- libs/dbuskit/branches/0.1/configure.ac 2012/01/20 14:38:55 34601
++++ libs/dbuskit/branches/0.1/configure.ac 2012/01/20 14:39:24 34602
+@@ -4,8 +4,17 @@
+ LT_INIT
+ AC_CONFIG_MACRO_DIR([m4])
+ AC_CANONICAL_SYSTEM
++
++#Override the OBJC variable if it is empty and CC is also set.
++if test -n "$CC"; then
++ if test -z "$OBJC"; then
++ OBJC="$CC"
++ fi
++fi
++
+ AC_PROG_CC(clang gcc cc c1 egcs)
+ AC_PROG_CPP
++AC_PROG_OBJC(clang gcc objcc objc cc CC)
+ AC_LANG(Objective C)
+ PKG_PROG_PKG_CONFIG([])
+ AC_LANG_PUSH(C)
+@@ -129,7 +138,7 @@
+ fi
+
+ AC_SUBST(OBJC_RUNTIME_H)
+-
++AC_SUBST(OBJC)
+ CFLAGS="$saved_CFLAGS"
+ CPPFLAGS="$saved_CPPFLAGS"
+ LDFLAGS="$saved_LDFLAGS"
diff --git a/gnustep-libs/dbuskit/metadata.xml b/gnustep-libs/dbuskit/metadata.xml
new file mode 100644
index 000000000000..4858c3463a27
--- /dev/null
+++ b/gnustep-libs/dbuskit/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>The DBusKit framework offers tight integration of D-Bus services into Objective-C applications. It handles all low-level details of communication with D-Bus daemons and the services connected to them and exposes an interface similar to Distributed Objects to make it easy for Objective-C programmers to access D-Bus services.</longdescription>
+</pkgmetadata>