summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-libs/sqlclient
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-libs/sqlclient')
-rw-r--r--gnustep-libs/sqlclient/Manifest1
-rw-r--r--gnustep-libs/sqlclient/metadata.xml8
-rw-r--r--gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild46
3 files changed, 55 insertions, 0 deletions
diff --git a/gnustep-libs/sqlclient/Manifest b/gnustep-libs/sqlclient/Manifest
new file mode 100644
index 000000000000..05a3d189a333
--- /dev/null
+++ b/gnustep-libs/sqlclient/Manifest
@@ -0,0 +1 @@
+DIST SQLClient-1.7.0.tar.gz 164218 SHA256 8f9c9491f774fce3bf369e407c8f22091c597baddc1a4b0bfe8ccb251bb79462 SHA512 cf4c9ec3bb60b57f4cc2673353029c77a0994c6912e9b5ee9bdab593b68663bde4a465cae6f39482c34fc0a5acff66ac2059be3644eb8db30a399c754e238809 WHIRLPOOL 153dd519969f437579ae3e24732c20c90fec5e141eddf746e4c55b35e7dadb388e4d0ae07b134ca0549e32f4cf6649d7ed1aa798e43498d57701dec664ae0cd0
diff --git a/gnustep-libs/sqlclient/metadata.xml b/gnustep-libs/sqlclient/metadata.xml
new file mode 100644
index 000000000000..530936af7529
--- /dev/null
+++ b/gnustep-libs/sqlclient/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>The SQLClient library is designed to provide a simple interface to SQL databases for GNUstep applications. It does not attempt the sort of abstraction provided by the much more sophisticated GDL2 library but rather allows applications to directly execute SQL queries and statements.
+
+SQLClient provides for the Objective-C programmer much the same thing that JDBC provides for the Java programmer (though SQLClient is a bit faster, easier to use, and easier to add new database backends for than JDBC).</longdescription>
+</pkgmetadata>
diff --git a/gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild b/gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild
new file mode 100644
index 000000000000..61c73ea9fb0a
--- /dev/null
+++ b/gnustep-libs/sqlclient/sqlclient-1.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit java-pkg-opt-2 gnustep-2
+
+MY_P=${P/sqlc/SQLC}
+DESCRIPTION="GNUstep lightweight database abstraction layer"
+HOMEPAGE="http://wiki.gnustep.org/index.php/SQLClient"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+IUSE="java mysql postgres +sqlite"
+
+RDEPEND=">=gnustep-libs/performance-0.3.2
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( >=dev-db/sqlite-3 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( java mysql postgres sqlite )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e '/documentation\.make/d' GNUmakefile \
+ || die "doc sed failed"
+ fi
+}
+
+src_configure() {
+ local myconf=""
+ use java || myconf="${myconf} --disable-jdbc-bundle"
+ use mysql || myconf="${myconf} --disable-mysql-bundle"
+ use postgres || myconf="${myconf} --disable-postgres-bundle"
+ use sqlite || myconf="${myconf} --disable-sqllite-bundle"
+
+ egnustep_env
+ econf ${myconf}
+}