summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-03-19 10:45:00 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-03-19 10:46:03 +0000
commit63863cc76e34787fc263fcf90ed0fd92acf24469 (patch)
tree510ff9ec56f2593f80cedd94e1e225c7169886b4 /gui-apps/wayvnc/wayvnc-0.6.2.ebuild
parentdev-libs/weston: Bump aml and neatvnc deps for 9999 (diff)
downloadgentoo-63863cc76e34787fc263fcf90ed0fd92acf24469.tar.gz
gentoo-63863cc76e34787fc263fcf90ed0fd92acf24469.tar.bz2
gentoo-63863cc76e34787fc263fcf90ed0fd92acf24469.zip
gui-apps/wayvnc: Bump to 0.6.2, drop old 0.4.0-r1
Locks the neatvnc dependency to a compatible version. Closes: https://bugs.gentoo.org/888641 Closes: https://bugs.gentoo.org/891113 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'gui-apps/wayvnc/wayvnc-0.6.2.ebuild')
-rw-r--r--gui-apps/wayvnc/wayvnc-0.6.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gui-apps/wayvnc/wayvnc-0.6.2.ebuild b/gui-apps/wayvnc/wayvnc-0.6.2.ebuild
new file mode 100644
index 000000000000..ea2a54a18724
--- /dev/null
+++ b/gui-apps/wayvnc/wayvnc-0.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="gbm tracing"
+
+RDEPEND="
+ =dev-libs/aml-0.3*
+ dev-libs/wayland
+ =gui-libs/neatvnc-0.6*[tracing?]
+ media-libs/mesa:=[egl(+),gles2,gbm(+)?]
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ tracing? ( dev-util/systemtap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_use tracing systemtap)
+ )
+ meson_src_configure
+}