summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-03 00:42:44 -0300
committerMatt Turner <mattst88@gentoo.org>2022-11-04 14:00:27 -0400
commit6d6d964477959f61f5192bb2606be55942996bed (patch)
tree3d9b0a72cd2d2e18e0577891ba25421cd4b88b65 /gui-libs/amtk
parentapp-editors/gnome-latex: Version bump to 3.42.0 (diff)
downloadgentoo-6d6d964477959f61f5192bb2606be55942996bed.tar.gz
gentoo-6d6d964477959f61f5192bb2606be55942996bed.tar.bz2
gentoo-6d6d964477959f61f5192bb2606be55942996bed.zip
gui-libs/amtk: Version bump to 5.6.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs/amtk')
-rw-r--r--gui-libs/amtk/Manifest1
-rw-r--r--gui-libs/amtk/amtk-5.6.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gui-libs/amtk/Manifest b/gui-libs/amtk/Manifest
index d7f0124d5ff3..fcb8b237e223 100644
--- a/gui-libs/amtk/Manifest
+++ b/gui-libs/amtk/Manifest
@@ -1 +1,2 @@
DIST amtk-5.4.1.tar.xz 58024 BLAKE2B aa65a5b8e9e4105d0ba699eef7e505ba3acb95a7014da1217b9569b68cb1ae7e7abf6debc1bd79935baa376e5a36ef197add3c3d326d97e89c7107c42ff4e582 SHA512 6257295c9c4756de622df48dd915cb591e5f3bf2d5d17dcb26f835e69c885d50e48a2634d8f7b9537638e7bdc531462670697823301ca2d257403192f6f8062c
+DIST amtk-5.6.0.tar.xz 58720 BLAKE2B 76770eef7148ce934621e8183fd0ed45e63e6078767a6af63160e406c2cb09320f6c79476d21f46e41ec2b7532216cab734931f6f3771b920e956c700145f5b8 SHA512 63e2d2a9f6d66cad9db4d18c2cfd6955aeb2cdcaf6bef7f1925f20e07507befd0d7ce9b9bee6edd9ac936cdb17c8ec5e4004ec5454b6c78740e85452b74f23f0
diff --git a/gui-libs/amtk/amtk-5.6.0.ebuild b/gui-libs/amtk/amtk-5.6.0.ebuild
new file mode 100644
index 000000000000..e6e139d016da
--- /dev/null
+++ b/gui-libs/amtk/amtk-5.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson
+
+DESCRIPTION="Actions, Menus and Toolbars Kit for GTK+ applications"
+HOMEPAGE="https://gitlab.gnome.org/World/amtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="5/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection gtk-doc"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ >=x11-libs/gtk+-3.22:3
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection gobject_introspection)
+ )
+ meson_src_configure
+}