summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-09-15 01:45:55 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-09-18 12:49:58 +0300
commit44d197f2b25aca0e0e4e46d3ad1f1beb8607804d (patch)
tree396288a15dff97c28fc1168d7330c67dfe185cf9 /gui-libs/greetd/greetd-0.8.0.ebuild
parentmedia-video/yle-dl: add 20210917 (diff)
downloadgentoo-44d197f2b25aca0e0e4e46d3ad1f1beb8607804d.tar.gz
gentoo-44d197f2b25aca0e0e4e46d3ad1f1beb8607804d.tar.bz2
gentoo-44d197f2b25aca0e0e4e46d3ad1f1beb8607804d.zip
gui-libs/greetd: bump to 0.8.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Closes: https://github.com/gentoo/gentoo/pull/22301 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-libs/greetd/greetd-0.8.0.ebuild')
-rw-r--r--gui-libs/greetd/greetd-0.8.0.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/gui-libs/greetd/greetd-0.8.0.ebuild b/gui-libs/greetd/greetd-0.8.0.ebuild
new file mode 100644
index 000000000000..9189883397cb
--- /dev/null
+++ b/gui-libs/greetd/greetd-0.8.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 2017-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.4.0
+
+EAPI=8
+
+CRATES="
+ arc-swap-0.4.6
+ async-trait-0.1.31
+ autocfg-1.0.1
+ bitflags-1.2.1
+ bytes-1.0.1
+ cc-1.0.53
+ cfg-if-0.1.10
+ cfg-if-1.0.0
+ enquote-1.0.3
+ getopts-0.2.21
+ itoa-0.4.5
+ libc-0.2.82
+ log-0.4.8
+ memchr-2.3.3
+ mio-0.7.7
+ miow-0.3.6
+ nix-0.19.1
+ ntapi-0.3.4
+ once_cell-1.5.2
+ pam-sys-0.5.6
+ pin-project-lite-0.2.4
+ proc-macro2-1.0.12
+ quote-1.0.5
+ rpassword-5.0.0
+ ryu-1.0.4
+ serde-1.0.110
+ serde_derive-1.0.110
+ serde_json-1.0.53
+ signal-hook-registry-1.2.0
+ socket2-0.3.19
+ syn-1.0.21
+ thiserror-1.0.17
+ thiserror-impl-1.0.17
+ tokio-1.0.2
+ tokio-macros-1.0.0
+ unicode-width-0.1.7
+ unicode-xid-0.2.0
+ users-0.11.0
+ winapi-0.3.8
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-x86_64-pc-windows-gnu-0.4.0
+"
+
+inherit cargo optfeature systemd
+
+DESCRIPTION="ipc based login daemon"
+
+HOMEPAGE="https://git.sr.ht/~kennylevinsen/greetd/"
+SRC_URI="https://git.sr.ht/~kennylevinsen/greetd/archive/${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris ${CRATES})
+"
+
+LICENSE="Apache-2.0 BSD Boost-1.0 GPL-3 MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+IUSE="man"
+
+DEPEND="
+ acct-user/greetd
+ sys-auth/pambase
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( app-text/scdoc )"
+
+QA_FLAGS_IGNORED="usr/bin/.*greet.*"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.1-correct_user_config_toml.patch"
+)
+
+src_compile() {
+ cargo_src_compile
+ if use man; then
+ scdoc < ./man/agreety-1.scd > ./agreety.1 || die
+ scdoc < ./man/greetd-1.scd > ./greetd.1 || die
+ scdoc < ./man/greetd-5.scd > ./greetd.5 || die
+ scdoc < ./man/greetd-ipc-7.scd > ./greetd-ipc.7 || die
+ fi
+}
+
+src_install() {
+ dobin target/release/{agreety,fakegreet,greetd}
+
+ insinto /etc/greetd
+ doins config.toml
+
+ systemd_dounit greetd.service
+
+ if use man; then
+ doman agreety.1 greetd.1 greetd.5 greetd-ipc.7
+ fi
+}
+
+pkg_postint() {
+ optfeature "eye-candy gtk based greeter" gui-apps/gtkgreet
+ optfeature "simplistic but sleek terminal greeter" gui-apps/tuigreet
+}