summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-03-15 15:43:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-16 21:18:11 +0200
commit610f9d51123e6a2e6628f66bb9cd6a4993d24e8e (patch)
treeba684a022de88273032055f4981cc9c767eff825 /gui-libs/wayfire-plugins-extra
parentgui-apps/wcm: update live ebuild (diff)
downloadgentoo-610f9d51123e6a2e6628f66bb9cd6a4993d24e8e.tar.gz
gentoo-610f9d51123e6a2e6628f66bb9cd6a4993d24e8e.tar.bz2
gentoo-610f9d51123e6a2e6628f66bb9cd6a4993d24e8e.zip
gui-libs/wayfire-plugins-extra: add 0.8.1
* Drop ~x86 due to wayfire-0.8.1 wlroots drm backend requirement. Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs/wayfire-plugins-extra')
-rw-r--r--gui-libs/wayfire-plugins-extra/Manifest1
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.8.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gui-libs/wayfire-plugins-extra/Manifest b/gui-libs/wayfire-plugins-extra/Manifest
index 2ea1d46e714f..7f5dba79ed57 100644
--- a/gui-libs/wayfire-plugins-extra/Manifest
+++ b/gui-libs/wayfire-plugins-extra/Manifest
@@ -1,2 +1,3 @@
DIST wayfire-plugins-extra-0.7.5.tar.xz 75136 BLAKE2B 7ffbb73f09175cc92f09b8a3f0493942741564278f95ff1d80066044b02ce4ceb925919ddb54fc6a37676b925d95ea7f93d09c6b0ccd448c6e9b821106d6e3ea SHA512 9cc816c3c727b0093fd15ef52dea215598b4c49ef96c098f53938c041b3908b30f4dd616be4b459b7382d630a47b36baf845c24de84f35670ba2912711205911
DIST wayfire-plugins-extra-0.8.0.tar.xz 70324 BLAKE2B f8f46782e31f170eb566567f50d302df4db23fbeb29c71569624a7f79c2bbcfcf48b070e7b55bf1880a9cd02afe78783d6680c457e466d765eb0db72f4b1f61b SHA512 8105fea3d8405a88d8c872c1012dadfab55f987a8ff8401f5caeec155214727021cbc7cfaba71c5ee3bc869caf136dcd78c189921c2f41a938b8552962f1597c
+DIST wayfire-plugins-extra-0.8.1.tar.xz 75908 BLAKE2B 65c14281fd9738864f2d63f01250e6384cdf46929ee6df653a5614805b89686f0020799246d6caf16b8d45aa16a66f314e705ae96c37188d892d339875ed4c03 SHA512 ebe12545b0a0ca1c443f334b9bfa31d1f446636dbef2b91c280715ad58d8802ab129f6894959727c0b872558f799c973a158e679683f915a5ef89b67087eed01
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.8.1.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.8.1.ebuild
new file mode 100644
index 000000000000..9a4704dc5c89
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="extra plugins for wayfire"
+HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+ SLOT="0/0.8"
+else
+ SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+
+# no tests
+RESTRICT="test"
+
+WAYFIRE_REVDEP="
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ gui-libs/wf-config:=
+ gui-libs/wlroots:=
+ x11-libs/cairo
+"
+
+DEPEND="
+ ${WAYFIRE_REVDEP}
+ dev-cpp/glibmm:2
+ dev-cpp/nlohmann_json
+ dev-libs/libevdev
+ dev-libs/wayland
+ >=gui-wm/wayfire-0.8.1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.12
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"