summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-11-26 00:43:08 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-17 21:55:17 +0200
commit4dc2fe5bb19af441bac36e3cfb49aadebe579ee2 (patch)
tree59df095d7671e85f7c767b28aeb8c114dc8063eb /gui-libs/wf-config/wf-config-0.8.0.ebuild
parentnet-misc/remmina: Add missing kde-frameworks/kwallet:5 slot dep (diff)
downloadgentoo-4dc2fe5bb19af441bac36e3cfb49aadebe579ee2.tar.gz
gentoo-4dc2fe5bb19af441bac36e3cfb49aadebe579ee2.tar.bz2
gentoo-4dc2fe5bb19af441bac36e3cfb49aadebe579ee2.zip
gui-libs/wf-config: add 0.8.0
Bug: https://bugs.gentoo.org/915795 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs/wf-config/wf-config-0.8.0.ebuild')
-rw-r--r--gui-libs/wf-config/wf-config-0.8.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gui-libs/wf-config/wf-config-0.8.0.ebuild b/gui-libs/wf-config/wf-config-0.8.0.ebuild
new file mode 100644
index 000000000000..4e970b7ae0aa
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ media-libs/glm
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+ test? ( dev-cpp/doctest )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test tests)
+ -Dlocale_test=false # requires de_DE locale to be installed
+ )
+
+ meson_src_configure
+}