summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-11-26 00:43:08 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-17 21:55:17 +0200
commit4dc2fe5bb19af441bac36e3cfb49aadebe579ee2 (patch)
tree59df095d7671e85f7c767b28aeb8c114dc8063eb /gui-libs/wf-config/wf-config-9999.ebuild
parentnet-misc/remmina: Add missing kde-frameworks/kwallet:5 slot dep (diff)
downloadgentoo-4dc2fe5bb19af441bac36e3cfb49aadebe579ee2.tar.gz
gentoo-4dc2fe5bb19af441bac36e3cfb49aadebe579ee2.tar.bz2
gentoo-4dc2fe5bb19af441bac36e3cfb49aadebe579ee2.zip
gui-libs/wf-config: add 0.8.0
Bug: https://bugs.gentoo.org/915795 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs/wf-config/wf-config-9999.ebuild')
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
index ae9b12db688b..4e970b7ae0aa 100644
--- a/gui-libs/wf-config/wf-config-9999.ebuild
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -11,13 +11,14 @@ HOMEPAGE="https://github.com/WayfireWM/wf-config"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -36,6 +37,7 @@ BDEPEND="
src_configure() {
local emesonargs=(
$(meson_feature test tests)
+ -Dlocale_test=false # requires de_DE locale to be installed
)
meson_src_configure