summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-17 18:23:18 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-17 18:23:31 +0100
commit27c3abb277ae958c4b0ae984c5409bc8e1d50342 (patch)
tree4174fab16d75e7ee44a17f3ea0aadc64a8d3a960 /gui-libs
parentsys-apps/usbutils: Python 3.8 compatibility (diff)
downloadgentoo-27c3abb277ae958c4b0ae984c5409bc8e1d50342.tar.gz
gentoo-27c3abb277ae958c4b0ae984c5409bc8e1d50342.tar.bz2
gentoo-27c3abb277ae958c4b0ae984c5409bc8e1d50342.zip
gui-libs/wlroots: tweak for gcc-10. bug #707496
Pull upstream f2943bdf61afe "Declare wlr_seat globals as extern". Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/707496 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/files/wlroots-0.10.0-gcc-10.patch26
-rw-r--r--gui-libs/wlroots/wlroots-0.10.0.ebuild2
2 files changed, 28 insertions, 0 deletions
diff --git a/gui-libs/wlroots/files/wlroots-0.10.0-gcc-10.patch b/gui-libs/wlroots/files/wlroots-0.10.0-gcc-10.patch
new file mode 100644
index 000000000000..44e1cb7d89b0
--- /dev/null
+++ b/gui-libs/wlroots/files/wlroots-0.10.0-gcc-10.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/707496
+
+From f2943bdf61afe0a3ad2227d72fcbcac8b3088b1a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan=20Stan=C4=9Bk?= <jstanek@redhat.com>
+Date: Tue, 28 Jan 2020 15:27:24 +0100
+Subject: [PATCH] Declare wlr_seat globals as extern
+
+---
+ include/types/wlr_seat.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- a/include/types/wlr_seat.h
++++ b/include/types/wlr_seat.h
+@@ -4,9 +4,9 @@
+ #include <wayland-server-core.h>
+ #include <wlr/types/wlr_seat.h>
+
+-const struct wlr_pointer_grab_interface default_pointer_grab_impl;
+-const struct wlr_keyboard_grab_interface default_keyboard_grab_impl;
+-const struct wlr_touch_grab_interface default_touch_grab_impl;
++extern const struct wlr_pointer_grab_interface default_pointer_grab_impl;
++extern const struct wlr_keyboard_grab_interface default_keyboard_grab_impl;
++extern const struct wlr_touch_grab_interface default_touch_grab_impl;
+
+ void seat_client_create_pointer(struct wlr_seat_client *seat_client,
+ uint32_t version, uint32_t id);
diff --git a/gui-libs/wlroots/wlroots-0.10.0.ebuild b/gui-libs/wlroots/wlroots-0.10.0.ebuild
index f408a513a4de..f1735761b739 100644
--- a/gui-libs/wlroots/wlroots-0.10.0.ebuild
+++ b/gui-libs/wlroots/wlroots-0.10.0.ebuild
@@ -47,6 +47,8 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
+
src_configure() {
# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(