summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-08 13:35:42 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-08 13:37:02 -0500
commit5cc23f3882c4026d7b1a7d27c9d825bad6cf947b (patch)
tree913f8a52768aca1bdb342199dc5497e7305d09da /gui-libs
parentacct-group/netdev: add 'netdev' group (GID 64) (diff)
downloadgentoo-5cc23f3882c4026d7b1a7d27c9d825bad6cf947b.tar.gz
gentoo-5cc23f3882c4026d7b1a7d27c9d825bad6cf947b.tar.bz2
gentoo-5cc23f3882c4026d7b1a7d27c9d825bad6cf947b.zip
gui-libs/wlroots: add patch to include EGL/eglmesaext.h
* Patch is currently in upstream master. Expect it to hit on next release (0.8.2+) Closes: https://bugs.gentoo.org/700114 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/files/wlroots-0.8.1-eglmesaextfix.patch25
-rw-r--r--gui-libs/wlroots/wlroots-0.8.1-r1.ebuild3
2 files changed, 28 insertions, 0 deletions
diff --git a/gui-libs/wlroots/files/wlroots-0.8.1-eglmesaextfix.patch b/gui-libs/wlroots/files/wlroots-0.8.1-eglmesaextfix.patch
new file mode 100644
index 000000000000..614d0c7a2cd4
--- /dev/null
+++ b/gui-libs/wlroots/files/wlroots-0.8.1-eglmesaextfix.patch
@@ -0,0 +1,25 @@
+From d113e48a2a32542fe6e12f1759f07888364609bf Mon Sep 17 00:00:00 2001
+From: Ferdinand Bachmann <theferdi265@gmail.com>
+Date: Sat, 19 Oct 2019 13:33:22 +0200
+Subject: [PATCH] Add missing include required by mesa and libglvnd change
+
+eglext.h no longer inludes eglmesaext.h, include it within wlroots
+explicitly.
+
+Fixes #1862
+---
+ glgen.sh | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/glgen.sh b/glgen.sh
+index 7324fdf6b..31af28120 100755
+--- a/glgen.sh
++++ b/glgen.sh
+@@ -75,6 +75,7 @@ cat > "$OUTDIR/$BASE.h" << EOF
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>
+ #include <GLES2/gl2.h>
+ #include <GLES2/gl2ext.h>
+
diff --git a/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild b/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild
index 50a4262598f9..51f138afcfd2 100644
--- a/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild
+++ b/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild
@@ -68,6 +68,9 @@ src_configure() {
emesonargs+=("-Dlogind=disabled")
fi
+ # Patch is currently in upstream master
+ eapply "${FILESDIR}/wlroots-0.8.1-eglmesaextfix.patch"
+
meson_src_configure
}