summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-12 17:12:49 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-12 17:59:24 -0400
commit93460744bbc9df2ab80d8bf45a5a26431057b80c (patch)
tree069d7ff0b62cfdd3c9382fadf9a683d39a5d5f3a /gui-libs
parentapp-dicts/gnome-dictionary: Version bump to 40.0 (diff)
downloadgentoo-93460744bbc9df2ab80d8bf45a5a26431057b80c.tar.gz
gentoo-93460744bbc9df2ab80d8bf45a5a26431057b80c.tar.bz2
gentoo-93460744bbc9df2ab80d8bf45a5a26431057b80c.zip
gui-libs/tepl: Version bump to 6.00.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/tepl/Manifest1
-rw-r--r--gui-libs/tepl/tepl-6.00.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gui-libs/tepl/Manifest b/gui-libs/tepl/Manifest
index a8a67d05f372..d6ceeddf244a 100644
--- a/gui-libs/tepl/Manifest
+++ b/gui-libs/tepl/Manifest
@@ -1,2 +1,3 @@
DIST tepl-4.4.0.tar.xz 466576 BLAKE2B fe9d9c625a3febe6fc71e5972b864b0d732b7f75bcc114a391d7f94b2fc242fe7c5199e61d5a69a8ceccb845fffcf830d6071adb1ecda5e223d453d029ed3398 SHA512 2050c28f9564034bea7c44d3fa27784ab87503c2db6cf35e6389c40ca78722b092fbc52df5fdfc85cc1e39a9dc3c0e30fa7993fb63411b0240f3a6ac9607c282
DIST tepl-5.0.1.tar.xz 126068 BLAKE2B 2c3038326660f6326c5030cb944f8cee885b794a481f6d8f1b5d87a8ea7121ded381d28b36246a99b57bbea5fd9e6d2d4f65f9dfc54d8154ee8aabbccd7e3cb5 SHA512 f363d182185976447d235cf1201148e5201cdabd1fa8b88d7a763a965896f87bd222a0161c11e93662afaf4e474bbd0308643d28559aadc27b9d48974f4c458d
+DIST tepl-6.00.0.tar.xz 141908 BLAKE2B 200693a8cf760d18e1c53647abb8156f7e067557b4cefbd05b03c5a3ec83c3c5807ab93e0464178b68fc9f2572c3175fbf9355f4131df1fe7f79b5e2deb3961e SHA512 e36877b9f33943715a50546d82ed61e65fc07b71dca2c85ff350a305767e96eda74dc14f30b2a430e14deacd4ee8d49697fe01df1f5023afab3747e5e9c95e2e
diff --git a/gui-libs/tepl/tepl-6.00.0.ebuild b/gui-libs/tepl/tepl-6.00.0.ebuild
new file mode 100644
index 000000000000..4e673848195b
--- /dev/null
+++ b/gui-libs/tepl/tepl-6.00.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Tepl"
+
+LICENSE="LGPL-2.1+"
+SLOT="6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc"
+
+RDEPEND="
+ >=dev-libs/glib-2.64:2
+ >=dev-libs/gobject-introspection-1.42:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=x11-libs/gtksourceview-4.0:4[introspection]
+ >=gui-libs/amtk-5.0:5[introspection]
+ >=dev-libs/libxml2-2.5:2
+ app-i18n/uchardet
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.6
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}