summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-10 21:19:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-12 23:13:15 +0200
commit83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b (patch)
treeb45546dce283baad7492c85797d5bc6f8e535918 /kde-apps/akonadi
parentkde-frameworks: Add KDE Frameworks 5.63.0 (diff)
downloadgentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.tar.gz
gentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.tar.bz2
gentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.zip
kde-apps: Add KDE Applications 19.08.2
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadi')
-rw-r--r--kde-apps/akonadi/Manifest1
-rw-r--r--kde-apps/akonadi/akonadi-19.08.2.ebuild124
2 files changed, 125 insertions, 0 deletions
diff --git a/kde-apps/akonadi/Manifest b/kde-apps/akonadi/Manifest
index de8bdd6d606b..97aa39fd9618 100644
--- a/kde-apps/akonadi/Manifest
+++ b/kde-apps/akonadi/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-19.04.3.tar.xz 1574868 BLAKE2B f520f5e8f8fc6480b6e44d6f91c561317b2d3460072c5473baccdf149c0e9eca5587cfeefaeacee0e504349624418a0ba5de7042866c0f5806de0b677f8f38a1 SHA512 62d7367ef87cd6fd7e26ae87dcc15df427f3b647618334a5ae67e722ca16dc2c7882152bd6172ab6a0982979f45271f6d65cc15b18f86e8a0ebf144b1bbe576a
DIST akonadi-19.08.1.tar.xz 1577172 BLAKE2B 034665bbf2550758cf063bd89fad83072cad8de1a9122da22b286c6c9d73eb8d0c7acf6b7cbf3a27ebbfede78eb6457751543cc7fd7eb5efaea2a86dea73ecbd SHA512 99aee26da19fca2a1a172f875a3ab4b1aee9c3ac92150f06df1dc3cf241144cb17b98d45a346ea09fa6fe96a7c8aafbea0a5b7b80e594b94f525de882d644d75
+DIST akonadi-19.08.2.tar.xz 1578452 BLAKE2B 87946dd8847064c353ab57d926ff767a292d20d44e50e7abc8defe5c1ccf3c82f5cc429176714c0c2f5c77ddb8a63a1da0b7c9367a55bd493e44d13f0173968a SHA512 80dc550a7502bde7edaf59c7fd765992569204ae5b56b9026e29c1b6103240b379ebe72c1b9804336d679aa0db3a3c2231140516d492d760497bdd59cff9b354
diff --git a/kde-apps/akonadi/akonadi-19.08.2.ebuild b/kde-apps/akonadi/akonadi-19.08.2.ebuild
new file mode 100644
index 000000000000..60a1a49252df
--- /dev/null
+++ b/kde-apps/akonadi/akonadi-19.08.2.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALDBUS_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Storage service for PIM data and libraries for PIM apps"
+HOMEPAGE="https://community.kde.org/KDE_PIM/akonadi"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+LICENSE="LGPL-2.1+"
+IUSE="+mysql postgres sqlite tools xml"
+
+REQUIRED_USE="|| ( mysql postgres sqlite ) test? ( tools )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsql 'mysql?,postgres?')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ sqlite? (
+ $(add_qt_dep qtsql 'sqlite' '' '5=')
+ dev-db/sqlite:3
+ )
+ xml? ( dev-libs/libxml2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ dev-libs/libxslt
+ test? ( sys-apps/dbus )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-apps/kapptemplate-17.11.80
+ !kde-apps/kdepim-l10n
+ !kde-apps/kdepimlibs
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${PN}-18.12.2-mysql56-crash.patch" )
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, PostgreSQL, SQLite
+ # reverse driver check to keep the order
+ use sqlite && DRIVER="QSQLITE3"
+ use postgres && DRIVER="QPSQL"
+ use mysql && DRIVER="QMYSQL"
+
+ if use mysql && has_version ">=dev-db/mariadb-10.4"; then
+ ewarn "If an existing Akonadi QMYSQL database is being upgraded using"
+ ewarn ">=dev-db/mariadb-10.4 and KMail stops fetching and sending mail,"
+ ewarn "check ~/.local/share/akonadi/akonadiserver.error for errors like:"
+ ewarn " \"Cannot add or update a child row: a foreign key constraint fails\""
+ ewarn
+ ewarn "Manual steps are required to fix it, see also:"
+ ewarn " https://bugs.gentoo.org/688746 (see Whiteboard)"
+ ewarn " https://bugs.kde.org/show_bug.cgi?id=409224"
+ ewarn
+ fi
+
+ if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
+ ewarn "We strongly recommend you change your Akonadi database backend to either MySQL"
+ ewarn "or PostgreSQL in your user configuration."
+ ewarn "In particular, kde-apps/kmail does not work properly with the sqlite backend."
+ fi
+
+ kde5_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAKONADI_BUILD_QSQLITE=$(usex sqlite)
+ -DBUILD_TOOLS=$(usex tools)
+ $(cmake-utils_use_find_package xml LibXml2)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ kde5_src_install
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "You can select the storage backend in ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are:"
+ use mysql && elog " QMYSQL"
+ use postgres && elog " QPSQL"
+ use sqlite && elog " QSQLITE3"
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+}