summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:29:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:30:09 +0200
commitd9397ab8d48feb4b1360be614da35fa2faae44d9 (patch)
treecc33135aeeb6bb0faab58e8efc34329c14dff2b0 /kde-apps/ark
parentdev-libs/libnl: Add USE='debug threads'. (diff)
downloadgentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.gz
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.bz2
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.zip
kde-apps: Add KDE Applications 18.04.1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-18.04.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 64a2de071036..7884581539ec 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-17.12.3.tar.xz 1970120 BLAKE2B b8e14f6b5f541c514107cf76b612edd99d6e0d97dfbe7600349bdcf2bd5afbfd1fcaf256d0358ff0c8838d8334a14ddd1ac5d29ce9befebe960444e0828aba5e SHA512 2f32f0107afa20ef115caddaf3c7ce6be37a575c72ea440f571312309d945a0e0491a4327db379e8ca7622a2b5016c5b2bbbfb3377d3b4272430f85b23fbb911
DIST ark-18.04.0.tar.xz 1969376 BLAKE2B 9d1e017c0d37307b8f8b9c7c0f9ec2be0d856c97cd39e0d928cd201553543883941baa4226a035e1cce9049125a80bde0d9a20da1159823bcc5d23be0fdaabff SHA512 0a6ab705bfec8af43c847f50580e97452e29ad83f34271ba09f5ec5eacefafe09b312149565ea802e25cf15597ecd78108e2581ebf52396af22f52aa228de69f
+DIST ark-18.04.1.tar.xz 1971344 BLAKE2B c1778e8777b6772f9ff72a23296b29daab9179c3ddc83297e46695f8e9b6c64490b3dad716104a5c9cbe936562481174a69d8356032caf901c0e8b91ae732ec2 SHA512 0a6a390f3771c4dc1d6386fcb17eac0416bc7494f6517d60a8007a676322b1986f6ff526ba8514a9f68913bd67f2105dfe9bfd1aa24feb2f19f67b442b1d1f8e
diff --git a/kde-apps/ark/ark-18.04.1.ebuild b/kde-apps/ark/ark-18.04.1.ebuild
new file mode 100644
index 000000000000..eb5ba8737873
--- /dev/null
+++ b/kde-apps/ark/ark-18.04.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}