summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:21:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:58:09 +0200
commitc1063afea17a29bb75dbbbf0121fa5c8ad948574 (patch)
treec62ccf9ec787742c39c2afd14ac1198894802629 /kde-apps/kdepim-runtime
parentmedia-libs/libqaccessibilityclient: New package (diff)
downloadgentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.gz
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.bz2
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.zip
kde-apps: Add KDE Applications 17.08.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/kdepim-runtime')
-rw-r--r--kde-apps/kdepim-runtime/Manifest1
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-17.08.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/Manifest b/kde-apps/kdepim-runtime/Manifest
index 1ee4ff34236a..2a4c5f8f25c8 100644
--- a/kde-apps/kdepim-runtime/Manifest
+++ b/kde-apps/kdepim-runtime/Manifest
@@ -1 +1,2 @@
DIST kdepim-runtime-17.04.3.tar.xz 1492480 SHA256 f85fa76556a5900861e3c9ccca4210af9ac66082109817d7b15d6295f4cecc1d SHA512 dd17f6bb3ba7372bad0e0647de13eb4d54f5d1a6c81f415eb037e7f90cc60fc0723922829282b57fa08559d1e85b4f46c17a7c4c0e85ee96516787fc78ed898d WHIRLPOOL f46ad65fd6a828de4129dffdb378731879c65a6695751bbda567cdc725a13acc7d9ee3bed2a2297847f3057787989d4cdcc2c8d18b19b4994e9379db0f028e23
+DIST kdepim-runtime-17.08.0.tar.xz 1505028 SHA256 c33772d620473383a942068f0c1b708580771502cf4210b3187fd06b423dbc55 SHA512 459024cbfe5a71a1b685a8a3f45342dd74203951465bead58f3b79640318e2a49eefab8d529c9855eeeddb25279d4b2d4c301e5ee7aa80e152346f5f9d9d57d3 WHIRLPOOL 4a8bc7d77070b070de837e7d8b41ea1cc9fbb6b218a98940fb12117db0364ff3280f05a2eebe3b4e4cb3012a9b27eb60e3230765668f034c4f72a83ec9b91deb
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-17.08.0.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-17.08.0.ebuild
new file mode 100644
index 000000000000..3314f6b82f89
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-17.08.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="google"
+
+# TODO kolab, Qt5TextToSpeech
+CDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep kalarmcal)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdav)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmbox)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+ dev-libs/libical:=
+ google? ( $(add_kdeapps_dep libkgapi) )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/libxslt
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-l10n
+ $(add_frameworks_dep oxygen-icons)
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package google KPimGAPI)
+ )
+
+ kde5_src_configure
+}