summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-10 14:28:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-11 23:00:24 +0100
commit8e9254c5dac34b290d80baa283964bf5802d6630 (patch)
treee74c0d8d4491416d64de7802e3937452a509b1f1 /kde-apps/kldap
parentkde-frameworks: Add KDE Frameworks 5.43.0 (diff)
downloadgentoo-8e9254c5dac34b290d80baa283964bf5802d6630.tar.gz
gentoo-8e9254c5dac34b290d80baa283964bf5802d6630.tar.bz2
gentoo-8e9254c5dac34b290d80baa283964bf5802d6630.zip
kde-apps: Add KDE Applications 17.12.2
Bug: https://bugs.gentoo.org/642854 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kldap')
-rw-r--r--kde-apps/kldap/Manifest1
-rw-r--r--kde-apps/kldap/kldap-17.12.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-apps/kldap/Manifest b/kde-apps/kldap/Manifest
index aef513c06cd7..7e8a8aabcace 100644
--- a/kde-apps/kldap/Manifest
+++ b/kde-apps/kldap/Manifest
@@ -1,2 +1,3 @@
DIST kldap-17.08.3.tar.xz 154864 BLAKE2B ecf22ab36150da39dcaa34b391864a7e6f7b3d4335e998089c9c7ebf582436aab0bd59cb3e04572dff74b2125ec5c243f8b2413bcb5be71168de4f44e3a30120 SHA512 b32fa8dfc9125a4f944aea710871268c64492cd4753a6be6f48f4bf314f9c66e56493c0d1bec0d3420edb6998971a9e1d941a050c038764e07b323b9dde8be53
DIST kldap-17.12.1.tar.xz 155140 BLAKE2B e2b1fbea22e8296c4a3849da3bca32fbcc371359f1b93ed77d96e6b0c0141936804a8e035a661cace3f56d495da0c73e77562e3f638921a5984d5a2cdfb3b5a7 SHA512 73d99db7f4f229fb44c90bd52c9929e8460cf44fc5e4ba734faa9e4a97b698afcee929ab23729a60ff0193d27f57bd5d00f4f81a14b882f7a824088de57ceaa3
+DIST kldap-17.12.2.tar.xz 155144 BLAKE2B 39552d4a8e52e2fc2e40996d27e4c2c4a60fd3ced3e490b906711509c027da8c79765852a25af380bb5c45caafe080787762a743de855febd58089a5f64a2900 SHA512 fc14fa15d56c895d9fb71a96c1802db834f2ffcbf06d8e1533d775c7e7b0d2fe36a05e4df33d360468671677558c96656e4d5681e24e34f6dc6513ece9a01b5d
diff --git a/kde-apps/kldap/kldap-17.12.2.ebuild b/kde-apps/kldap/kldap-17.12.2.ebuild
new file mode 100644
index 000000000000..fd1452bcfd54
--- /dev/null
+++ b/kde-apps/kldap/kldap-17.12.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Library for interacting with LDAP servers"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/cyrus-sasl
+ net-nds/openldap
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use_if_iuse handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}