summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/kmix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/kmix')
-rw-r--r--kde-apps/kmix/Manifest1
-rw-r--r--kde-apps/kmix/files/kmix-4.14.3-alsa-optional.patch47
-rw-r--r--kde-apps/kmix/kmix-4.14.3-r1.ebuild32
-rw-r--r--kde-apps/kmix/kmix-4.14.3.ebuild30
-rw-r--r--kde-apps/kmix/metadata.xml8
5 files changed, 118 insertions, 0 deletions
diff --git a/kde-apps/kmix/Manifest b/kde-apps/kmix/Manifest
new file mode 100644
index 000000000000..c5d900570775
--- /dev/null
+++ b/kde-apps/kmix/Manifest
@@ -0,0 +1 @@
+DIST kmix-4.14.3.tar.xz 379220 SHA256 d7dd97ad5ee005fa039696d88ce21a6ede2b5d795001f1d023899f5a848b6e94 SHA512 b4581a8f847618088b55710815c45a64fe22d1ea782aa57d8e724237cf4283a49d005e2c6389974e0587352d10da46718d7a696e4faafce63950288ab7b6cd62 WHIRLPOOL ac9ae7bb39d21de53eb2932720e2f0d7d6784b071343fd04a1c69de551b80a9993a6dc525c3c90643e6098bcfb6f3662dcfe4e5389194ed581cee066fca8d3e7
diff --git a/kde-apps/kmix/files/kmix-4.14.3-alsa-optional.patch b/kde-apps/kmix/files/kmix-4.14.3-alsa-optional.patch
new file mode 100644
index 000000000000..4f620fbac828
--- /dev/null
+++ b/kde-apps/kmix/files/kmix-4.14.3-alsa-optional.patch
@@ -0,0 +1,47 @@
+commit 233f93b01ff05349793a8a2786750a2195f257ab
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sat Jul 11 15:48:35 2015 +0200
+
+ Fix build w/ optional alsa, make HAVE_LIBASOUND2 work
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c829005..17c106d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -9,8 +9,6 @@ include(MacroLibrary)
+ # Do not yet REQUIRE Phonon. Hint: As long as we do not find_package(), ${KDE4_PHONON_LIBS} will be empty below, but that should not hurt.
+ #find_package(Phonon REQUIRED)
+
+-find_package(Alsa)
+-
+ set(PA_VER "0.9.16")
+ macro_optional_find_package(PulseAudio "${PA_VER}")
+ macro_log_feature(PULSEAUDIO_FOUND "PulseAudio" "PulseAudio Audio Server"
+@@ -20,8 +18,11 @@ macro_optional_find_package(Canberra)
+ macro_log_feature(CANBERRA_FOUND "libcanberra" "libcanberra audio library"
+ "http://0pointer.de/lennart/projects/libcanberra/" FALSE "" "libcanberra is needed for kmix sound feedback")
+
+-alsa_configure_file(${CMAKE_BINARY_DIR}/config-alsa.h)
+-
++find_package(Alsa)
++if(ALSA_FOUND)
++ alsa_configure_file(${CMAKE_BINARY_DIR}/config-alsa.h)
++ add_definitions(-DHAVE_LIBASOUND2)
++endif(ALSA_FOUND)
+
+ add_definitions (${QT_DEFINITIONS} ${QT_QTDBUS_DEFINITIONS} ${KDE4_DEFINITIONS} )
+ add_definitions(-DKDE_DEFAULT_DEBUG_AREA=67100)
+diff --git a/backends/kmix-backends.cpp b/backends/kmix-backends.cpp
+index 14ecfb3..1397099 100644
+--- a/backends/kmix-backends.cpp
++++ b/backends/kmix-backends.cpp
+@@ -23,7 +23,9 @@
+ /* This code is being #include'd from mixer.cpp */
+
+ #include <config.h>
++#ifdef HAVE_LIBASOUND2
+ #include <config-alsa.h>
++#endif
+
+ #include "mixer_backend.h"
+ #include "core/mixer.h"
diff --git a/kde-apps/kmix/kmix-4.14.3-r1.ebuild b/kde-apps/kmix/kmix-4.14.3-r1.ebuild
new file mode 100644
index 000000000000..e84d9a18472f
--- /dev/null
+++ b/kde-apps/kmix/kmix-4.14.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE mixer gui"
+HOMEPAGE="http://www.kde.org/applications/multimedia/kmix/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa debug canberra pulseaudio"
+
+DEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.14a )
+ canberra? ( media-libs/libcanberra )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.12 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.14.3-alsa-optional.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package alsa)
+ $(cmake-utils_use_with canberra)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/kmix/kmix-4.14.3.ebuild b/kde-apps/kmix/kmix-4.14.3.ebuild
new file mode 100644
index 000000000000..65ad0f9febae
--- /dev/null
+++ b/kde-apps/kmix/kmix-4.14.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE mixer gui"
+HOMEPAGE="http://www.kde.org/applications/multimedia/kmix/"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="alsa debug canberra pulseaudio"
+
+DEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.14a )
+ canberra? ( media-libs/libcanberra )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.12 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with canberra)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/kmix/metadata.xml b/kde-apps/kmix/metadata.xml
new file mode 100644
index 000000000000..8afb87d73fc9
--- /dev/null
+++ b/kde-apps/kmix/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="canberra">Enable sound event support using <pkg>media-libs/libcanberra</pkg></flag>
+ </use>
+</pkgmetadata>