summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-12-19 20:58:16 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-19 21:08:29 +0100
commit37eeb8d60efea8ccaefb977428f20c9f12ae2513 (patch)
treef6a3b1ec0a4587af0a9ccc74d66718edbfacad21 /kde-apps/ktouch
parentkde-apps/kdepim-runtime: Remove 16.12.0 (r0) (diff)
downloadgentoo-37eeb8d60efea8ccaefb977428f20c9f12ae2513.tar.gz
gentoo-37eeb8d60efea8ccaefb977428f20c9f12ae2513.tar.bz2
gentoo-37eeb8d60efea8ccaefb977428f20c9f12ae2513.zip
kde-apps/ktouch: Fix DEPENDs
Gentoo-bug: 602982 Package-Manager: portage-2.3.0 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'kde-apps/ktouch')
-rw-r--r--kde-apps/ktouch/files/ktouch-16.12.0-deps.patch78
-rw-r--r--kde-apps/ktouch/ktouch-16.12.0-r1.ebuild44
2 files changed, 122 insertions, 0 deletions
diff --git a/kde-apps/ktouch/files/ktouch-16.12.0-deps.patch b/kde-apps/ktouch/files/ktouch-16.12.0-deps.patch
new file mode 100644
index 000000000000..2dbfe7607396
--- /dev/null
+++ b/kde-apps/ktouch/files/ktouch-16.12.0-deps.patch
@@ -0,0 +1,78 @@
+commit 6bc9417c81e1c5792da313fb15b4e0b222f2d7ca
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Mon Dec 19 20:47:50 2016 +0100
+
+ Fix and sort dependencies
+
+ REVIEW: 129676
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7a0099c..3175453 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,32 +25,32 @@ include(ECMSetupVersion)
+ include(FeatureSummary)
+
+ find_package(Qt5 5.5 REQUIRED COMPONENTS
+- Widgets
+- Sql
+- Script
+- XmlPatterns
++ Gui
+ Qml
+ Quick
+ QuickWidgets
++ Script
++ Sql
+ Test
++ Widgets
+ X11Extras
++ Xml
++ XmlPatterns
+ )
+
+ find_package(KF5 REQUIRED COMPONENTS
++ Completion
+ Config
+ ConfigWidgets
+ CoreAddons
+ Declarative
+ DocTools
+ I18n
+- KIO
+- NewStuff
+- WidgetsAddons
+- XmlGui
+ ItemViews
+ KCMUtils
+- TextEditor
+- WindowSystem
++ TextWidgets
++ WidgetsAddons
++ XmlGui
+ )
+
+ # subdirectories to build
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 6633f35..1003a0b 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -131,16 +131,14 @@ target_link_libraries(ktouch
+ Qt5::Sql
+ Qt5::XmlPatterns
+ Qt5::X11Extras
++ KF5::Completion
+ KF5::ConfigWidgets
+ KF5::Declarative
+- KF5::KIOWidgets
+ KF5::ItemViews
+- KF5::NewStuff
+ KF5::XmlGui
+ KF5::I18n
+ KF5::KCMUtils
+- KF5::TextEditor
+- KF5::WindowSystem
++ KF5::TextWidgets
+ KF5::CoreAddons
+ ${ktouch_X11_DEPS}
+ )
diff --git a/kde-apps/ktouch/ktouch-16.12.0-r1.ebuild b/kde-apps/ktouch/ktouch-16.12.0-r1.ebuild
new file mode 100644
index 000000000000..cd6216cb7b30
--- /dev/null
+++ b/kde-apps/ktouch/ktouch-16.12.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Program that helps to learn and practice touch typing"
+HOMEPAGE="https://www.kde.org/applications/education/ktouch/"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kqtquickcharts)
+"
+
+PATCHES=( "${FILESDIR}/${P}"-deps.patch )