summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-12 20:36:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-12 20:36:02 +0200
commit4186eabcad11c1cf1a6fdc6a555b72404eee0137 (patch)
tree7a07ac977ec9f17772623b3ec02801d5dad964f9 /kde-apps/thumbnailers/thumbnailers-18.04.3.ebuild
parentapp-crypt/certbot: fixing acme dep (diff)
downloadgentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.tar.gz
gentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.tar.bz2
gentoo-4186eabcad11c1cf1a6fdc6a555b72404eee0137.zip
kde-apps: Add KDE Applications 18.04.3
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'kde-apps/thumbnailers/thumbnailers-18.04.3.ebuild')
-rw-r--r--kde-apps/thumbnailers/thumbnailers-18.04.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/thumbnailers-18.04.3.ebuild b/kde-apps/thumbnailers/thumbnailers-18.04.3.ebuild
new file mode 100644
index 000000000000..ff1362dbc75b
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-18.04.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4=false
+KMNAME="kdegraphics-thumbnailers"
+inherit kde5
+
+DESCRIPTION="Thumbnail generators for PDF/PS and RAW files"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="raw"
+
+DEPEND="
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtgui)
+ raw? (
+ $(add_kdeapps_dep libkdcraw)
+ $(add_kdeapps_dep libkexiv2)
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package raw KF5KExiv2)
+ $(cmake-utils_use_find_package raw KF5KDcraw)
+ )
+
+ kde5_src_configure
+}