summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/qyoto
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/Manifest1
-rw-r--r--kde-base/qyoto/metadata.xml10
-rw-r--r--kde-base/qyoto/qyoto-4.14.3.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/kde-base/qyoto/Manifest b/kde-base/qyoto/Manifest
new file mode 100644
index 000000000000..2c5290167a98
--- /dev/null
+++ b/kde-base/qyoto/Manifest
@@ -0,0 +1 @@
+DIST qyoto-4.14.3.tar.xz 507640 SHA256 44a6e2eacc4645cc0e217812948518860661dc52215af005726cc40ab96ddc46 SHA512 4e74a6a8a1ef501490d5680b3c47fd83153798e9c226f39175c5710b78f26854d01611df2e3b5e052369d82d56b72b14696a7599debeca788f30c0fcefe9d46b WHIRLPOOL c684fa80650ea34523d496faeb2f00e189a6019a11e15d3ce6010864f31ec94e5baac626c4ee83ca674ee9a104ef0e7e2e6f78b3943db25d2fb0898e6b43654a
diff --git a/kde-base/qyoto/metadata.xml b/kde-base/qyoto/metadata.xml
new file mode 100644
index 000000000000..b069b55c8cb2
--- /dev/null
+++ b/kde-base/qyoto/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<use>
+ <flag name="phonon">Compile bindings for Phonon.</flag>
+ <flag name="qscintilla">Compile bindings for <pkg>x11-libs/qscintilla</pkg>.</flag>
+ <flag name="webkit">Compile bindings for <pkg>dev-qt/qtwebkit</pkg>.</flag>
+</use>
+</pkgmetadata>
diff --git a/kde-base/qyoto/qyoto-4.14.3.ebuild b/kde-base/qyoto/qyoto-4.14.3.ebuild
new file mode 100644
index 000000000000..cfdb9af04a8a
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.14.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Qyoto"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}