summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-08-12 23:54:56 +0200
committerJohannes Huber <johu@gentoo.org>2015-08-13 00:03:32 +0200
commitc1d0beb1494967633a2ae69eb86e068c84bebfdc (patch)
tree008f25a684f95a45b2d69f2a5e175c667c98fba3 /kde-base
parentkde-base/plasma-workspace: Drop Nepomuk support (diff)
downloadgentoo-c1d0beb1494967633a2ae69eb86e068c84bebfdc.tar.gz
gentoo-c1d0beb1494967633a2ae69eb86e068c84bebfdc.tar.bz2
gentoo-c1d0beb1494967633a2ae69eb86e068c84bebfdc.zip
kde-base/pykde4: Drop Nepomuk support
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/pykde4/metadata.xml1
-rw-r--r--kde-base/pykde4/pykde4-4.14.3.ebuild13
2 files changed, 6 insertions, 8 deletions
diff --git a/kde-base/pykde4/metadata.xml b/kde-base/pykde4/metadata.xml
index 7ceb431b93b..b4e222ad6dd 100644
--- a/kde-base/pykde4/metadata.xml
+++ b/kde-base/pykde4/metadata.xml
@@ -4,6 +4,5 @@
<herd>kde</herd>
<use>
<flag name="akonadi">Compile bindings for Akonadi</flag>
- <flag name="nepomuk">Compile bindings for Nepomuk</flag>
</use>
</pkgmetadata>
diff --git a/kde-base/pykde4/pykde4-4.14.3.ebuild b/kde-base/pykde4/pykde4-4.14.3.ebuild
index 685c471bd25..c227acb5baf 100644
--- a/kde-base/pykde4/pykde4-4.14.3.ebuild
+++ b/kde-base/pykde4/pykde4-4.14.3.ebuild
@@ -11,18 +11,17 @@ inherit python-r1 portability kde4-base multilib eutils
DESCRIPTION="Python bindings for KDE4"
KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="akonadi debug doc examples nepomuk test"
+IUSE="akonadi debug doc examples test"
HOMEPAGE="http://techbase.kde.org/Development/Languages/Python"
-REQUIRED_USE="${PYTHON_REQUIRED_USE} test? ( nepomuk )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
>=dev-python/PyQt4-4.11.1[${PYTHON_USEDEP},dbus,declarative,script,sql,svg,webkit,X]
>=dev-python/sip-4.16.2:=[${PYTHON_USEDEP}]
- $(add_kdebase_dep kdelibs 'nepomuk?,opengl')
+ $(add_kdebase_dep kdelibs 'opengl')
akonadi? ( $(add_kdebase_dep kdepimlibs) )
- nepomuk? ( >=dev-libs/soprano-2.9.0 )
"
DEPEND="${RDEPEND}
dev-lang/python-exec:2[${PYTHON_USEDEP}]
@@ -74,11 +73,11 @@ src_configure() {
local mycmakeargs=(
-DWITH_PolkitQt=OFF
-DWITH_QScintilla=OFF
+ -DPYKDEUIC4_ALTINSTALL=TRUE
+ -DWITH_Nepomuk=OFF
+ -DWITH_Soprano=OFF
$(cmake-utils_use_with akonadi KdepimLibs)
- $(cmake-utils_use_with nepomuk)
- $(cmake-utils_use_with nepomuk Soprano)
-DPYTHON_EXECUTABLE=${PYTHON}
- -DPYKDEUIC4_ALTINSTALL=TRUE
)
local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
kde4-base_src_configure