summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-08-20 00:03:30 +1000
committerMichael Palimaka <kensington@gentoo.org>2018-08-20 00:07:54 +1000
commita49d8c2a95711b9f166c59e3be0df26b75b88290 (patch)
tree6972a435dc9482c119aa50bc28fd6b5ee06d630e /kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.49.0-r1.ebuild
parentgames-simulation/openrct2: drop old (diff)
downloadgentoo-a49d8c2a95711b9f166c59e3be0df26b75b88290.tar.gz
gentoo-a49d8c2a95711b9f166c59e3be0df26b75b88290.tar.bz2
gentoo-a49d8c2a95711b9f166c59e3be0df26b75b88290.zip
kde-frameworks/extra-cmake-modules: avoid build failure with GCC8 and ld.gold
Bug: https://bugs.gentoo.org/663512 Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.49.0-r1.ebuild')
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.49.0-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.49.0-r1.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.49.0-r1.ebuild
new file mode 100644
index 000000000000..7003678df8f5
--- /dev/null
+++ b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.49.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+KDE_AUTODEPS="false"
+KDE_DEBUG="false"
+KDE_QTHELP="false"
+KDE_TEST="false"
+inherit kde5 python-any-r1
+
+DESCRIPTION="Extra modules and scripts for CMake"
+HOMEPAGE="https://cgit.kde.org/extra-cmake-modules.git"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+DEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+ test? (
+ $(add_qt_dep qtcore)
+ $(add_qt_dep linguist-tools)
+ )
+"
+RDEPEND="
+ app-arch/libarchive[bzip2]
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch" )
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_HTML_DOCS="$(usex doc)"
+ -DBUILD_MAN_DOCS="$(usex doc)"
+ -DDOC_INSTALL_DIR="/usr/share/doc/${PF}"
+ )
+ use test && mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # ECMToolchainAndroidTest passes but then breaks src_install
+ # ECMPoQmToolsTest is broken, bug #627806
+ local myctestargs=(
+ -E "(ECMToolchainAndroidTest|ECMPoQmToolsTest)"
+ )
+
+ kde5_src_test
+}