summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-10 01:19:43 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-10 10:58:35 +0200
commit3a433556dffc41d462cbce30e8a5c097e9f73d2f (patch)
tree4fed51d583dd7dc07364b58a762fb1fd2732177b /kde-frameworks/kauth/kauth-5.47.0.ebuild
parentmedia-libs/libkate: Drop 0.4.1-r2 (diff)
downloadgentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.tar.gz
gentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.tar.bz2
gentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.zip
kde-frameworks: Add KDE Frameworks 5.47.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/kauth/kauth-5.47.0.ebuild')
-rw-r--r--kde-frameworks/kauth/kauth-5.47.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/kauth-5.47.0.ebuild b/kde-frameworks/kauth/kauth-5.47.0.ebuild
new file mode 100644
index 000000000000..ee6570cb1d6b
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.47.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}