summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 10:24:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 15:35:00 +0100
commit9f729a3ed257b5878ea19a9bae536e90546dde9d (patch)
tree4cf6fbf0ff3bfc39b541d81b55fb2cfee0a64827 /kde-frameworks/kauth
parentdev-lang/mujs: stabilize v1.0.5 on amd64 (diff)
downloadgentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.tar.gz
gentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.tar.bz2
gentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.zip
kde-frameworks: Add KDE Frameworks 5.54.0
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.54.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index f13c025e2129..9d7c3e70232f 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.52.0.tar.xz 84716 BLAKE2B 142725f21bb2bbbd985a22f580088dfc8fc399db96295d3b24a65dcb2bac89d9ff0dadef87bcea798f85e858df0f013cc4e849295a537ac2fac7cede92b0f30b SHA512 62b9da8e867f4256b9210ef210cc5d7230064c8c7096f0765061f2e3010cce64abd6d7324daf5a48e952b8bfe38fb5efecd7448e0ec16968dbf27c913dcc8b14
DIST kauth-5.53.0.tar.xz 84728 BLAKE2B 41d654d2cb4cfd3daca4271d875e430b6a1160a4a8778aae59a16552b92892265d1c18101bccf0f55b7b46d93e87226482963b0233e90783f2f7586af9b79ab4 SHA512 f4b99b0282ff3caafeaf304739ce5c52268c01245e6ea7582a32a85b4afa0addac141a58c9fa66304165dc91269950474ea79623ae934ca673dcec34d3da0629
+DIST kauth-5.54.0.tar.xz 84688 BLAKE2B beba564ccc64af52b772ce827b756fad493e3e4926e6bb8b7b65154bf6b7a1753a211e98dd12c67bba844412610ff08f39b9e34a0aadc6c2fc87f4a25e4090bc SHA512 f75c6f019d708409817a5b64d88033326a7d627cdee00e61280043d5cd8f65731f08d48405f50c7240f18670b25abfeea4b2af5966ebb2ee7e0f56669b5551c2
diff --git a/kde-frameworks/kauth/kauth-5.54.0.ebuild b/kde-frameworks/kauth/kauth-5.54.0.ebuild
new file mode 100644
index 000000000000..d2b08d9b8d01
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.54.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ kde5_src_test
+}