summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-17 00:24:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-17 08:09:45 +0200
commitf573d19bc059eacd037d2ea656b67e14dcaafa2d (patch)
tree3abe7b53ee35cfb7527bdfc70b129ee28a63802d /kde-frameworks/kdesu/kdesu-5.57.0.ebuild
parentkde-misc/latte-dock: 0.8.8 version bump (diff)
downloadgentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.tar.gz
gentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.tar.bz2
gentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.zip
kde-frameworks: Add KDE Frameworks 5.57.0
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.57.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.57.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.57.0.ebuild b/kde-frameworks/kdesu/kdesu-5.57.0.ebuild
new file mode 100644
index 000000000000..19af92e08b02
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.57.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Framework to handle super user actions"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}