summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 12:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 13:58:34 +0100
commitb5f0806e00fadca2d0c9819e9ab46b0d4c2da58f (patch)
tree651d11303c1a4fdb7aae0dd382ce043ffb840404 /kde-frameworks/ki18n
parentapp-emulation/qemu: bump up to 4.2.0, bug #702036 (diff)
downloadgentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.gz
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.bz2
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.zip
kde-frameworks: Add KDE Frameworks 5.65
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/ki18n')
-rw-r--r--kde-frameworks/ki18n/Manifest1
-rw-r--r--kde-frameworks/ki18n/ki18n-5.65.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/Manifest b/kde-frameworks/ki18n/Manifest
index c3caacce4f7..fc9d9529160 100644
--- a/kde-frameworks/ki18n/Manifest
+++ b/kde-frameworks/ki18n/Manifest
@@ -1 +1,2 @@
DIST ki18n-5.64.0.tar.xz 586948 BLAKE2B 9c3989f530ccaba3bc43f0e30aa9426c8eadca88cbaa44538d8d47ae71442163d31f4593fcc5d34f59e3542f03dd8b9eed90dbf57299f2ddf285632aae0bd893 SHA512 68e65934a19621850a189b9aeb24b48a3bb8ea493ed5af1e490030154f759b653aaf0e1a27b5579ad36ca3cb249c7ef72b7429dbc70aa27be827a608b68577c3
+DIST ki18n-5.65.0.tar.xz 585068 BLAKE2B 46c5112ac26d2841a97f19aed3a9ea06299f4afdc177e49ba4cd68f077898c3bbba48661ac34d1e0b0e4e604534f6b8f014006aa43ff7e06f12008598fc29d7b SHA512 5d18b42d9026d49543ac58728870d9b1367c6f2d5bec2d5edc88844fc6f2b3077d164d617c5ff3166d663e920886c1742bc60374d3fb6bacae6ab2457ebce323
diff --git a/kde-frameworks/ki18n/ki18n-5.65.0.ebuild b/kde-frameworks/ki18n/ki18n-5.65.0.ebuild
new file mode 100644
index 00000000000..18971d98dd6
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.65.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+QTMIN=5.12.3
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtconcurrent-${QTMIN}:5 )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.57.0-python.patch" )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ ecm_src_configure
+}